I cannot able to install grafana on raspberry pi

Hi, Grafana team and community members,

I need your help with grafana installation process on raspberry-pi.

  • I’m trying to install grafana on Raspberry Pi 4 Model-B with 4 GB RAM having 64-bit Debian OS running on top of it.

  • For grafana installation, i’m following step-by-step procedure as discussed in grafana tutorial Link

  • In the step-3, when i ran " sudo apt-get install -y grafana", i got errors[refer pic]

Can you tell me what i’m doing wrong? Any help would be appreciated…

~ Thank you

Hi @shubhamtestandforget and welcome to the Grafana forum.

Normally I could try to reproduce your issue on a Pi 4 that I have lying around, but today is not that day unfortunately. In the meantime, I think this blog post from late Sep 2023 (a few months after the instructions in the link you included were published) may possibly be the reason why it has not worked for you.

Edit: Maybe not…just noticed you were referenced 64-bit, while the above blog post referenced 32-bit.