Grafana on Raspberry Pi 4

I’m looking for a version of Grafana for the new Raspberry PI 4.
They have changed the CPU to a Broadcom BCM2711B0 quad-core A72 (ARMv8-A). Rpi 3 was using a Broadcom BCM2837B0 quad-core A53 (ARMv8).
I have tried to install the https://dl.grafana.com/oss/release/grafana_6.3.3_armhf.deb that is working for a Rpi3B+, but it seems not to be working on a Pi4…

After install I get
● grafana-server.service - Grafana instance
Loaded: loaded (/usr/lib/systemd/system/grafana-server.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2019-08-22 07:54:52 CEST; 7h ago
Docs: http://docs.grafana.org
Process: 6837 ExecStart=/usr/sbin/grafana-server --config={CONF_FILE} --pidfile={PID_FILE_DIR}/grafana-server.pid --packaging=deb cfg:default.paths.logs={LOG_DIR} cfg:default.paths.data={DATA_DIR} cfg:default.
Main PID: 6837 (code=exited, status=1/FAILURE)

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
lines 1-8/8 (END)

When asking for the status of the service.
The outcome is simular when running the wrong dist on a pi zero. Is it nessasary to get another dist. from Rpi 4 as well, or should the one I tested work on a pi4?

Best regards
Ola

Hi Ola,

The release you linked to is built for ARMv7 (32 bit) (link), which may be why it’s not working on your Raspberry Pi 4, ARMv8 (64 bit).

I don’t have the hardware to verify it, but have you tried the ARM64 release?
https://dl.grafana.com/oss/release/grafana_6.3.3_arm64.deb

Let me know how it goes!

Marcus

Hi Marcus,

Thanks for youre reply. I did just test with the arm64 package, and unfortunately it didn’t work.
The result I got is the folowing:

pi@Raspberry4:~ $ sudo dpkg -i grafana_6.3.3_arm64.deb
dpkg: error processing archive grafana_6.3.3_arm64.deb (–install):
package architecture (arm64) does not match system (armhf)
Errors were encountered while processing:
grafana_6.3.3_arm64.deb

Best regards
Ola

Put the armhf version back, then look in /var/log/grafana.log and see if there is anything there when you try to start it. If not then look in /var/log/syslog.

Thanks clanlaw!

I don’t know what when wrong the first time. Now it works fine!

If anyone is looking for how I did it, here are the commands:
–Update your apt source
wget https://dl.grafana.com/oss/release/grafana_6.3.3_armhf.deb
sudo dpkg -i grafana_6.3.3_armhf.deb
–Update available packages and Install Grafana
sudo apt-get update
sudo apt --fix-broken install
–Start the server
sudo /bin/systemctl daemon-reload
sudo /bin/systemctl enable grafana-server
sudo /bin/systemctl start grafana-server
sudo update-rc.d grafana-server defaults

Best regards

Ola

I’m glad it worked out for you! Thanks for sharing your solution!

I don’t believe that is required is it? All that is handled by systemd now. Certainly I have not done that for years.
You don’t need the /bin/ on the front of systemctl either.