Change 1.071 MWh to 1,071 MWh

In Germany there are always Irritation here when you see a dot in the number, the dot is to separate between one hundred and the thousand place and therefore the number is much too big.

It shows 1071 MWh instead of 1071 kWh. Until a few days ago, when we were under a thousand, the world was still in order

Is there a way to replace the dot with a comma?

what do you get when you set the following

I do not have the setting at this point Standard options Unit.
Do I have to preset this somewhere else? I am unfortunately a complete beginner in grafana

what version of grafana are you on? and does influxql have way of formatting those numbers?

It is under Misc:


THX ebabeshko
That was the solution. Now I have the numbers in the correct format.

Is there still a possibility to add a text to the number? so that you can see the unit kWh again. I have written the unit in the Titel, but it doesn’t look as professional as before.

As of now it is not possible, although such feature was requested long time ago:

1 Like

In my opinion Grafana should simply follow the machine’s locale settings, as
so many other applications do; that would fix several things at once:

  • decimal and thousands symbols
  • date format DD/MM/YYYY, MM/DD/YYYY, YYYY/MM/DD
  • time format 12h/24h
  • possibly even currency symbol too


1 Like