Can't access Grafana web interface trought port 3000?

Hey guys. So I’ve just installed Grafana and I can’t seem to be able to access the web interface trought my browser (getting ERR_CONNECTION_TIMED_OUT). I’ve installed Grafana in the same virtual machine where I got Zabbix up and running so I should be able to get to the web interface with the same IP address as Zabbix (http://zabbix-ip:3000), right?

The weird thing is that when I check the log file it doesn’t seem to have any problems:

t=2019-04-24T17:09:32+0000 lvl=info msg=“Starting Grafana” logger=server version=6.1.4 commit=fef1733 branch=HEAD compiled=2019-04-16T09:04:07+0000
t=2019-04-24T17:09:32+0000 lvl=info msg=“Config loaded from” logger=settings file=/usr/share/grafana/conf/defaults.ini
t=2019-04-24T17:09:32+0000 lvl=info msg=“Config loaded from” logger=settings file=/etc/grafana/grafana.ini
t=2019-04-24T17:09:32+0000 lvl=info msg=“Config overridden from command line” logger=settings arg=“default.paths.data=/var/lib/grafana”
t=2019-04-24T17:09:32+0000 lvl=info msg=“Config overridden from command line” logger=settings arg=“default.paths.logs=/var/log/grafana”
t=2019-04-24T17:09:32+0000 lvl=info msg=“Config overridden from command line” logger=settings arg=“default.paths.plugins=/var/lib/grafana/plugins”
t=2019-04-24T17:09:32+0000 lvl=info msg=“Config overridden from command line” logger=settings arg=“default.paths.provisioning=/etc/grafana/provisioning”
t=2019-04-24T17:09:32+0000 lvl=info msg=“Path Home” logger=settings path=/usr/share/grafana
t=2019-04-24T17:09:32+0000 lvl=info msg=“Path Data” logger=settings path=/var/lib/grafana
t=2019-04-24T17:09:32+0000 lvl=info msg=“Path Logs” logger=settings path=/var/log/grafana
t=2019-04-24T17:09:32+0000 lvl=info msg=“Path Plugins” logger=settings path=/var/lib/grafana/plugins
t=2019-04-24T17:09:32+0000 lvl=info msg=“Path Provisioning” logger=settings path=/etc/grafana/provisioning
t=2019-04-24T17:09:32+0000 lvl=info msg=“App mode production” logger=settings
t=2019-04-24T17:09:32+0000 lvl=info msg=“Writing PID file” logger=server path=/var/run/grafana/grafana-server.pid pid=25164
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing HTTPServer” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing SqlStore” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Connecting to DB” logger=sqlstore dbtype=sqlite3
t=2019-04-24T17:09:32+0000 lvl=info msg=“Starting DB migration” logger=migrator
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing InternalMetricsService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing SearchService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing PluginManager” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Starting plugin search” logger=plugins
t=2019-04-24T17:09:32+0000 lvl=info msg=“Registering plugin” logger=plugins name=Zabbix
t=2019-04-24T17:09:32+0000 lvl=info msg=“Registering plugin” logger=plugins name=“Zabbix Problems”
t=2019-04-24T17:09:32+0000 lvl=info msg=“Registering plugin” logger=plugins name=Zabbix
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing RenderingService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing SqlStore” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Connecting to DB” logger=sqlstore dbtype=sqlite3
t=2019-04-24T17:09:32+0000 lvl=info msg=“Starting DB migration” logger=migrator
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing InternalMetricsService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing SearchService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing PluginManager” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Starting plugin search” logger=plugins
t=2019-04-24T17:09:32+0000 lvl=info msg=“Registering plugin” logger=plugins name=Zabbix
t=2019-04-24T17:09:32+0000 lvl=info msg=“Registering plugin” logger=plugins name=“Zabbix Problems”
t=2019-04-24T17:09:32+0000 lvl=info msg=“Registering plugin” logger=plugins name=Zabbix
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing RenderingService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing AlertingService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing DatasourceCacheService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing HooksService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing LoginService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing QuotaService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing RemoteCache” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing ServerLockService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing TracingService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing UsageStatsService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing UserAuthTokenService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing CleanUpService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing NotificationService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing ProvisioningService” logger=server
t=2019-04-24T17:09:32+0000 lvl=info msg=“Initializing Stream Manager”
t=2019-04-24T17:09:32+0000 lvl=info msg=“HTTP Server Listen” logger=http.server address=0.0.0.0:3000 protocol=http subUrl= socket=
t=2019-04-24T17:36:45+0000 lvl=info msg=“Request Completed” logger=context userId=0 orgId=0 uname= method=GET path=/ status=302 remote_addr=10.100.100.242 time_ms=0 size=29 referer =$

The IP where Zabbix is running is 10.100.100.242/zabbix and when I run these commands on the port 3000 I get the following outputs:

input: nc -v 10.100.100.242 3000
output: Connection to 10.100.100.242 3000 port [tcp/*] succeeded!

HTTP/1.1 400 Bad Request
Content-Type: text/plain; charset=utf-8
Connection: close

input: nmap -p 3000 10.100.100.242
output:     Starting Nmap 7.01 ( https://nmap.org ) at 2019-04-24 18:18 UTC
Nmap scan report for zabbix.zabbix.lan (10.100.100.242)
Host is up (0.000069s latency).
PORT     STATE SERVICE
3000/tcp open  ppp

input: wget 10.100.100.242:3000
output:     --2019-04-24 18:20:13--  http://10.100.100.242:3000/
Connecting to 10.100.100.242:3000... connected.
HTTP request sent, awaiting response... 302 Found
Location: /login [following]
--2019-04-24 18:20:13--  http://10.100.100.242:3000/login
Reusing existing connection to 10.100.100.242:3000.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: ‘index.html’

index.html.2                    [ <=>                                       ]  22.04K  --.-KB/s    in 0s

2019-04-24 18:20:13 (461 MB/s) - ‘index.html’ saved [22568]

Where the file is a description of what I believe should be the login screen of grafana on the browser.


input: netstat -tulpn
output:     
.................................................................
    tcp6       0      0 :::3000                 :::*                    LISTEN      25164/grafana-serve
.................................................................

input: curl -I http://10.100.100.242:3000
output:     HTTP/1.1 302 Found
Content-Type: text/html; charset=utf-8
Location: /login
Set-Cookie: redirect_to=%252F; Path=/; HttpOnly
Date: Wed, 24 Apr 2019 18:26:12 GMT

So from the results of these commands I believe the port is available and working as it should be, but I still can’t connect via browser. This is my grafana.ini file configuration for the server:

#################################### Server ####################################
[server]
 Protocol (http, https, socket)
;protocol = http

 The ip address to bind to, empty will bind to all interfaces
;http_addr =

 The http port  to use
;http_port = 3000

 The public facing domain name used to access grafana from a browser
;domain = localhost

 Redirect to correct domain if host header does not match domain
 Prevents DNS rebinding attacks
;enforce_domain = false

 The full public facing url you use in browser, used for redirects and emails
 If you use reverse proxy and sub path specify full url (with sub path)
;root_url = http://localhost:3000

 Log web requests
;router_logging = false

 the path relative working path
;static_root_path = public

I’ve tried to set http_addr to 10.100.100.242 but nothing changed and I don’t know what else to do. Can anyone give me a hand please?

Thank you!

What exactly are you putting in the browser url?

I’m typing: http://10.100.100.242:3000
I also tried http://0.0.0.0:3000 and localhost:3000 but none of those worked. I’ve been reading and I think that what I need to do is reverse proxing on the apache webserver, but I’m not sure…

So are you saying that http://10.100.100.242:3000 in the browser doesn’t work, but in a terminal on the same machine that is running the browser that
wget http://10.100.100.242:3000
does work?
Have a look in the browser developer console to see what is going on.
I presume the browser is not set to offline working? Can you access other sites?

Please use curl -vL http://10.100.100.242:3000 and show the result have you already tried with a private browser window ?

Yes, exaclty. I can access other sites normally.
I’ve look into chrome developer tool but it doesn’t show any erros in console when I try to access the link. On firefox it shows the following warning:
DOM7011 : The code on this page disabled back and forward caching.

Yes I’ve tried a private browser window and the result is the same.
The output to this command is:

* Rebuilt URL to: http://10.100.100.242:3000/
  • Trying 10.100.100.242…
  • Connected to 10.100.100.242 (10.100.100.242) port 3000 (#0)

GET / HTTP/1.1
Host: 10.100.100.242:3000
User-Agent: curl/7.47.0
Accept: /

< HTTP/1.1 302 Found
< Content-Type: text/html; charset=utf-8
< Location: /login
< Set-Cookie: redirect_to=%252F; Path=/; HttpOnly
< Date: Wed, 24 Apr 2019 23:08:15 GMT
< Content-Length: 29
<

  • Ignoring the response-body
  • Connection #0 to host 10.100.100.242 left intact
  • Issue another request to this URL: ‘http://10.100.100.242:3000/login
  • Found bundle for host 10.100.100.242: 0x55b03d353f20 [can pipeline]
  • Re-using existing connection! (#0) with host 10.100.100.242
  • Connected to 10.100.100.242 (10.100.100.242) port 3000 (#0)

GET /login HTTP/1.1
Host: 10.100.100.242:3000
User-Agent: curl/7.47.0
Accept: /

< HTTP/1.1 200 OK
< Content-Type: text/html; charset=UTF-8
< Date: Wed, 24 Apr 2019 23:08:15 GMT
< Transfer-Encoding: chunked
<

Grafana .preloader { height: 100%; flex-direction: column; display: flex; justify-content: center; align-items: center; } .preloader__enter { opacity: 0; animation-name: preloader-fade-in; animation-iteration-count: 1; animation-duration: .9s; animation-delay: 1.35s; animation-fill-mode: forwards; } .preloader__bounce { text-align: center; animation-name: preloader-bounce; animation-duration: .9s; animation-iteration-count: infinite; } .preloader__logo { display: inline-block; animation-name: preloader-squash; animation-duration: .9s; animation-iteration-count: infinite; width: 60px; height: 60px; background-repeat: no-repeat; background-size: contain; background-image: url("data:image/svg+xml,%3csvg version='1.1' id='Layer_1 ' xmlns='http://www.w3.org/2000/svg' xmlns:xlink='http://www.w3.org/1999/xlink' x='0px' y='0px' width='351px' height='365px' viewBox='0 0 351 365' style='enable -background:new 0 0 351 365%3b' xml:space='preserve'%3e %3cstyle type='text/css' %3e .st0%7bfill:url(%23SVGID_1_)%3b%7d %3c/style%3e %3cg id='Layer_1_1_'%3e %3c/ g%3e %3clinearGradient id='SVGID_1_' gradientUnits='userSpaceOnUse' x1='175.5' y 1='445.4948' x2='175.5' y2='114.0346'%3e %3cstop offset='0' style='stop-color:%2 3FFF100'/%3e %3cstop offset='1' style='stop-color:%23F05A28'/%3e %3c/linearGradi ent%3e %3cpath class='st0' d='M342%2c161.2c-0.6-6.1-1.6-13.1-3.6-20.9c-2-7.7-5-1 6.2-9.4-25c-4.4-8.8-10.1-17.9-17.5-26.8 c-2.9-3.5-6.1-6.9-9.5-10.2c5.1-20.3-6.2- 37.9-6.2-37.9c-19.5-1.2-31.9%2c6.1-36.5%2c9.4c-0.8-0.3-1.5-0.7-2.3-1 c-3.3-1.3-6 .7-2.6-10.3-3.7c-3.5-1.1-7.1-2.1-10.8-3c-3.7-0.9-7.4-1.6-11.2-2.2c-0.7-0.1-1.3-0 .2-2-0.3 c-8.5-27.2-32.9-38.6-32.9-38.6c-27.3%2c17.3-32.4%2c41.5-32.4%2c41.5s-0. 1%2c0.5-0.3%2c1.4c-1.5%2c0.4-3%2c0.9-4.5%2c1.3c-2.1%2c0.6-4.2%2c1.4-6.2%2c2.2 c- 2.1%2c0.8-4.1%2c1.6-6.2%2c2.5c-4.1%2c1.8-8.2%2c3.8-12.2%2c6c-3.9%2c2.2-7.7%2c4.6 -11.4%2c7.1c-0.5-0.2-1-0.4-1-0.4c-37.8-14.4-71.3%2c2.9-71.3%2c2.9 c-3.1%2c40.2%2 c15.1%2c65.5%2c18.7%2c70.1c-0.9%2c2.5-1.7%2c5-2.5%2c7.5c-2.8%2c9.1-4.9%2c18.4-6. 2%2c28.1c-0.2%2c1.4-0.4%2c2.8-0.5%2c4.2 C18.8%2c192.7%2c8.5%2c228%2c8.5%2c228c29 .1%2c33.5%2c63.1%2c35.6%2c63.1%2c35.6c0%2c0%2c0.1-0.1%2c0.1-0.1c4.3%2c7.7%2c9.3% 2c15%2c14.9%2c21.9c2.4%2c2.9%2c4.8%2c5.6%2c7.4%2c8.3 c-10.6%2c30.4%2c1.5%2c55.6% 2c1.5%2c55.6c32.4%2c1.2%2c53.7-14.2%2c58.2-17.7c3.2%2c1.1%2c6.5%2c2.1%2c9.8%2c2. 9c10%2c2.6%2c20.2%2c4.1%2c30.4%2c4.5 c2.5%2c0.1%2c5.1%2c0.2%2c7.6%2c0.1l1.2%2c0l 0.8%2c0l1.6%2c0l1.6-0.1l0%2c0.1c15.3%2c21.8%2c42.1%2c24.9%2c42.1%2c24.9c19.1-20. 1%2c20.2-40.1%2c20.2-44.4l0%2c0 c0%2c0%2c0-0.1%2c0-0.3c0-0.4%2c0-0.6%2c0-0.6l0%2 c0c0-0.3%2c0-0.6%2c0-0.9c4-2.8%2c7.8-5.8%2c11.4-9.1c7.6-6.9%2c14.3-14.8%2c19.9-2 3.3 c0.5-0.8%2c1-1.6%2c1.5-2.4c21.6%2c1.2%2c36.9-13.4%2c36.9-13.4c-3.6-22.5-16.4 -33.5-19.1-35.6l0%2c0c0%2c0-0.1-0.1-0.3-0.2 c-0.2-0.1-0.2-0.2-0.2-0.2c0%2c0%2c0% 2c0%2c0%2c0c-0.1-0.1-0.3-0.2-0.5-0.3c0.1-1.4%2c0.2-2.7%2c0.3-4.1c0.2-2.4%2c0.2-4 .9%2c0.2-7.3l0-1.8l0-0.9 l0-0.5c0-0.6%2c0-0.4%2c0-0.6l-0.1-1.5l-0.1-2c0-0.7-0.1- 1.3-0.2-1.9c-0.1-0.6-0.1-1.3-0.2-1.9l-0.2-1.9l-0.3-1.9 c-0.4-2.5-0.8-4.9-1.4-7.4 c-2.3-9.7-6.1-18.9-11-27.2c-5-8.3-11.2-15.6-18.3-21.8c-7-6.2-14.9-11.2-23.1-14.9 c-8.3-3.7-16.9-6.1-25.5-7.2c-4.3-0.6-8.6-0.8-12.9-0.7l-1.6%2c0l-0.4%2c0c-0.1%2c 0-0.6%2c0-0.5%2c0l-0.7%2c0l-1.6%2c0.1c-0.6%2c0-1.2%2c0.1-1.7%2c0.1 c-2.2%2c0.2-4 .4%2c0.5-6.5%2c0.9c-8.6%2c1.6-16.7%2c4.7-23.8%2c9c-7.1%2c4.3-13.3%2c9.6-18.3%2c1 5.6c-5%2c6-8.9%2c12.7-11.6%2c19.6c-2.7%2c6.9-4.2%2c14.1-4.6%2c21 c-0.1%2c1.7-0.1 %2c3.5-0.1%2c5.2c0%2c0.4%2c0%2c0.9%2c0%2c1.3l0.1%2c1.4c0.1%2c0.8%2c0.1%2c1.7%2c0 .2%2c2.5c0.3%2c3.5%2c1%2c6.9%2c1.9%2c10.1c1.9%2c6.5%2c4.9%2c12.4%2c8.6%2c17.4 c3 .7%2c5%2c8.2%2c9.1%2c12.9%2c12.4c4.7%2c3.2%2c9.8%2c5.5%2c14.8%2c7c5%2c1.5%2c10%2 c2.1%2c14.7%2c2.1c0.6%2c0%2c1.2%2c0%2c1.7%2c0c0.3%2c0%2c0.6%2c0%2c0.9%2c0c0.3%2c 0%2c0.6%2c0%2c0.9-0.1 c0.5%2c0%2c1-0.1%2c1.5-0.1c0.1%2c0%2c0.3%2c0%2c0.4-0.1l0.5 -0.1c0.3%2c0%2c0.6-0.1%2c0.9-0.1c0.6-0.1%2c1.1-0.2%2c1.7-0.3c0.6-0.1%2c1.1-0.2%2 c1.6-0.4 c1.1-0.2%2c2.1-0.6%2c3.1-0.9c2-0.7%2c4-1.5%2c5.7-2.4c1.8-0.9%2c3.4-2%2c 5-3c0.4-0.3%2c0.9-0.6%2c1.3-1c1.6-1.3%2c1.9-3.7%2c0.6-5.3 c-1.1-1.4-3.1-1.8-4.7- 0.9c-0.4%2c0.2-0.8%2c0.4-1.2%2c0.6c-1.4%2c0.7-2.8%2c1.3-4.3%2c1.8c-1.5%2c0.5-3.1 %2c0.9-4.7%2c1.2c-0.8%2c0.1-1.6%2c0.2-2.5%2c0.3 c-0.4%2c0-0.8%2c0.1-1.3%2c0.1c-0 .4%2c0-0.9%2c0-1.2%2c0c-0.4%2c0-0.8%2c0-1.2%2c0c-0.5%2c0-1%2c0-1.5-0.1c0%2c0-0.3 %2c0-0.1%2c0l-0.2%2c0l-0.3%2c0 c-0.2%2c0-0.5%2c0-0.7-0.1c-0.5-0.1-0.9-0.1-1.4-0. 2c-3.7-0.5-7.4-1.6-10.9-3.2c-3.6-1.6-7-3.8-10.1-6.6c-3.1-2.8-5.8-6.1-7.9-9.9 c-2 .1-3.8-3.6-8-4.3-12.4c-0.3-2.2-0.5-4.5-0.4-6.7c0-0.6%2c0.1-1.2%2c0.1-1.8c0%2c0.2 %2c0-0.1%2c0-0.1l0-0.2l0-0.5c0-0.3%2c0.1-0.6%2c0.1-0.9 c0.1-1.2%2c0.3-2.4%2c0.5- 3.6c1.7-9.6%2c6.5-19%2c13.9-26.1c1.9-1.8%2c3.9-3.4%2c6-4.9c2.1-1.5%2c4.4-2.8%2c6 .8-3.9c2.4-1.1%2c4.8-2%2c7.4-2.7 c2.5-0.7%2c5.1-1.1%2c7.8-1.4c1.3-0.1%2c2.6-0.2% 2c4-0.2c0.4%2c0%2c0.6%2c0%2c0.9%2c0l1.1%2c0l0.7%2c0c0.3%2c0%2c0%2c0%2c0.1%2c0l0. 3%2c0l1.1%2c0.1 c2.9%2c0.2%2c5.7%2c0.6%2c8.5%2c1.3c5.6%2c1.2%2c11.1%2c3.3%2c16.2 %2c6.1c10.2%2c5.7%2c18.9%2c14.5%2c24.2%2c25.1c2.7%2c5.3%2c4.6%2c11%2c5.5%2c16.9c 0.2%2c1.5%2c0.4%2c3%2c0.5%2c4.5 l0.1%2c1.1l0.1%2c1.1c0%2c0.4%2c0%2c0.8%2c0%2c1.1 c0%2c0.4%2c0%2c0.8%2c0%2c1.1l0%2c1l0%2c1.1c0%2c0.7-0.1%2c1.9-0.1%2c2.6c-0.1%2c1. 6-0.3%2c3.3-0.5%2c4.9 c-0.2%2c1.6-0.5%2c3.2-0.8%2c4.8c-0.3%2c1.6-0.7%2c3.2-1.1%2 c4.7c-0.8%2c3.1-1.8%2c6.2-3%2c9.3c-2.4%2c6-5.6%2c11.8-9.4%2c17.1 c-7.7%2c10.6-18 .2%2c19.2-30.2%2c24.7c-6%2c2.7-12.3%2c4.7-18.8%2c5.7c-3.2%2c0.6-6.5%2c0.9-9.8%2c 1l-0.6%2c0l-0.5%2c0l-1.1%2c0l-1.6%2c0l-0.8%2c0 c0.4%2c0-0.1%2c0-0.1%2c0l-0.3%2c0 c-1.8%2c0-3.5-0.1-5.3-0.3c-7-0.5-13.9-1.8-20.7-3.7c-6.7-1.9-13.2-4.6-19.4-7.8 c- 12.3-6.6-23.4-15.6-32-26.5c-4.3-5.4-8.1-11.3-11.2-17.4c-3.1-6.1-5.6-12.6-7.4-19. 1c-1.8-6.6-2.9-13.3-3.4-20.1l-0.1-1.3l0-0.3 l0-0.3l0-0.6l0-1.1l0-0.3l0-0.4l0-0.8 l0-1.6l0-0.3c0%2c0%2c0%2c0.1%2c0-0.1l0-0.6c0-0.8%2c0-1.7%2c0-2.5c0.1-3.3%2c0.4-6 .8%2c0.8-10.2 c0.4-3.4%2c1-6.9%2c1.7-10.3c0.7-3.4%2c1.5-6.8%2c2.5-10.2c1.9-6.7%2 c4.3-13.2%2c7.1-19.3c5.7-12.2%2c13.1-23.1%2c22-31.8c2.2-2.2%2c4.5-4.2%2c6.9-6.2 c2.4-1.9%2c4.9-3.7%2c7.5-5.4c2.5-1.7%2c5.2-3.2%2c7.9-4.6c1.3-0.7%2c2.7-1.4%2c4.1 -2c0.7-0.3%2c1.4-0.6%2c2.1-0.9c0.7-0.3%2c1.4-0.6%2c2.1-0.9 c2.8-1.2%2c5.7-2.2%2c 8.7-3.1c0.7-0.2%2c1.5-0.4%2c2.2-0.7c0.7-0.2%2c1.5-0.4%2c2.2-0.6c1.5-0.4%2c3-0.8% 2c4.5-1.1c0.7-0.2%2c1.5-0.3%2c2.3-0.5 c0.8-0.2%2c1.5-0.3%2c2.3-0.5c0.8-0.1%2c1.5 -0.3%2c2.3-0.4l1.1-0.2l1.2-0.2c0.8-0.1%2c1.5-0.2%2c2.3-0.3c0.9-0.1%2c1.7-0.2%2c2 .6-0.3 c0.7-0.1%2c1.9-0.2%2c2.6-0.3c0.5-0.1%2c1.1-0.1%2c1.6-0.2l1.1-0.1l0.5-0.1l 0.6%2c0c0.9-0.1%2c1.7-0.1%2c2.6-0.2l1.3-0.1c0%2c0%2c0.5%2c0%2c0.1%2c0l0.3%2c0 l0 .6%2c0c0.7%2c0%2c1.5-0.1%2c2.2-0.1c2.9-0.1%2c5.9-0.1%2c8.8%2c0c5.8%2c0.2%2c11.5% 2c0.9%2c17%2c1.9c11.1%2c2.1%2c21.5%2c5.6%2c31%2c10.3 c9.5%2c4.6%2c17.9%2c10.3%2c 25.3%2c16.5c0.5%2c0.4%2c0.9%2c0.8%2c1.4%2c1.2c0.4%2c0.4%2c0.9%2c0.8%2c1.3%2c1.2c 0.9%2c0.8%2c1.7%2c1.6%2c2.6%2c2.4c0.9%2c0.8%2c1.7%2c1.6%2c2.5%2c2.4 c0.8%2c0.8%2 c1.6%2c1.6%2c2.4%2c2.5c3.1%2c3.3%2c6%2c6.6%2c8.6%2c10c5.2%2c6.7%2c9.4%2c13.5%2c1 2.7%2c19.9c0.2%2c0.4%2c0.4%2c0.8%2c0.6%2c1.2c0.2%2c0.4%2c0.4%2c0.8%2c0.6%2c1.2 c 0.4%2c0.8%2c0.8%2c1.6%2c1.1%2c2.4c0.4%2c0.8%2c0.7%2c1.5%2c1.1%2c2.3c0.3%2c0.8%2c 0.7%2c1.5%2c1%2c2.3c1.2%2c3%2c2.4%2c5.9%2c3.3%2c8.6c1.5%2c4.4%2c2.6%2c8.3%2c3.5% 2c11.7 c0.3%2c1.4%2c1.6%2c2.3%2c3%2c2.1c1.5-0.1%2c2.6-1.3%2c2.6-2.8C342.6%2c170. 4%2c342.5%2c166.1%2c342%2c161.2z'/%3e %3c/svg%3e"); } .preloader__text { margin-top: 16px; font-weight: 500; font-size: 14px; font-family: Sans-serif; opacity: 0; animation-name: preloader-fade-in; animation-duration: .9s; animation-delay: 1.8s; animation-fill-mode: forwards; } .theme-light .preloader__text { color: #52545c; } .theme-dark .preloader__text { color: #d8d9da; } @keyframes preloader-fade-in { 0% { opacity: 0; animation-timing-function: cubic-bezier(0, 0, 0.5, 1) } 100% { opacity: 1; } } @keyframes preloader-bounce { from, to { transform: translateY(0px); animation-timing-function: cubic-bezier(0.3, 0.0, 0.1, 1) } 50% { transform: translateY(-50px); animation-timing-function: cubic-bezier(.9, 0, .7, 1) } } @keyframes preloader-squash { 0% { transform: scaleX(1.3) scaleY(.8); animation-timing-function: cubic-bezier(.3, 0, .1, 1); transform-origin: bottom center; } 15% { transform: scaleX(.75) scaleY(1.25); animation-timing-function: cubic-bezier(0, 0, .7, .75); transform-origin: bottom center; } 55% { transform: scaleX(1.05) scaleY(.95); animation-timing-function: cubic-bezier(.9, 0, 1, 1); transform-origin: top center; } 95% { transform: scaleX(.75) scaleY(1.25); animation-timing-function: cubic-bezier(0, 0, 0, 1); transform-origin: bottom center; } 100% { transform: scaleX(1.3) scaleY(.8); transform-origin: bottom center; animation-timing-function: cubic-bezier(0, 0, 0.7, 1); } } .preloader__text--fail { display: none; } .preloader--done .preloader__bounce, .preloader--done .preloader__logo { animation-name: none; display: none; } .preloader--done .preloader__logo, .preloader--done .preloader__text { display: none; color: #ff5705 !important; font-size: 15px; } .preloader--done .preloader__text--fail { display: block; } [ng\:cloak], [ng-cloak], .ng-cloak { display: none !important; }
Loading Grafana

If you're seeing this Grafana has failed to load its application f iles

1. This could be caused by your reverse proxy settings.

2. If you host grafana under subpath make sure your grafana.ini root_url setting includes subpath

3. If you have a local dev build make sure you build frontend using: yar n start, yarn start:hot, or yarn build

4. Sometimes restarting grafana-server can help

<div class="main-view">
  <div class="scroll-canvas">
    <div ng-view></div>

    <footer class="footer">
      <div class="text-center">
        <ul>
          <li>
            <a href="http://docs.grafana.org" target="_blank">
              <i class="fa fa-file-code-o"></i>
              Docs
            </a>
          </li>
          <li>
            <a href="https://grafana.com/services/support" target="_blank">
              <i class="fa fa-support"></i>
              Support Plans
            </a>
          </li>
          <li>
            <a href="https://community.grafana.com/" target="_blank">
              <i class="fa fa-comments-o"></i>
              Community
            </a>
          </li>
          <li>
            <a href="https://grafana.com" target="_blank">Grafana</a>
            <span>v6.1.4 (commit: fef1733)</span>
          </li>

        </ul>
      </div>
    </footer>
  </div>
</div>
* Connection #0 to host 10.100.100.242 left intact

At the end looks like it shows an error but i’m not sure how to solve it (I’m an intern and don’t know much about these topics).

Guys, problem solved!
It was the firewall rules on the virtual machine that were blocking the access to the web browser.
So with the iptables -F command I cleared all rules and now I’m able to access Grafana trought the link 10.100.100.242:3000.
Thanks for the help!

3 Likes

Hi @mbellini , I have the same issue but I checked everything (firewall stream, selinux, config network, conf file…) ,… I changed the network of my servers, I have graylog and Grafana installed on the same server (Os: centos7), the problem that after the modifications at the network level, I did not access the web interface of grafana, however I can access the web interface of graylog, I restart the grafana server service and I check his status ( active).
Please Help,

This is the grafana server service status and the server logs