Cannot get New Version 8 Alerts Working

  • What Grafana version and what operating system are you using?
    8.0.6 / Ubuntu 20.04

  • What are you trying to achieve?
    Looking to enable ngalert feature

  • How are you trying to achieve it?
    Edit /etc/grafana/grafana.ini to include

[feature_toggles]
# enable features, separated by spaces
enable = ngalert
  • What happened?
    Updated the ini file as above, used systemctl to restart service, alerting seems to be the same

  • What did you expect to happen?
    New alerting capabilities and ability to create alerts from alerting section instead of only on panels.

  • Can you copy/paste the configuration(s) that you are having problems with?

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.
    Not sure if this is an error, but this warn line was in the logs

t=2021-07-19T19:44:25+0000 lvl=warn msg="Request Origin is not authorized" logger=live origin=http://192.168.1.12:3000 appUrl=http://localhost:3000/ allowedOrigins=
  • Did you follow any online instructions? If so, what is the URL?

Hi @nef

To troubleshoot this, can you try and run this command to start grafana in a container with ngalert enabled?

docker run -p 3000:3000 -e "GF_FEATURE_TOGGLES_ENABLE=ngalert" grafana/grafana:8.1.0-beta3

Hi @mattabrams

What I ended up trying was updating another server that was running version 7. The difference was that in this case I updated the config file prior to updating the instance. Seems like this was an important difference in the order of operations.

This has worked and the ngalert feature is working.

As the server I opened the case for, I am just going to rebuild it after exporting my custom dashboards. The server was fairly new anyhow and had not yet hit production.

Thanks for your help

1 Like

This topic was automatically closed after 365 days. New replies are no longer allowed.