Candlestick chart doesn't display volume as values are too small

I am using version 9.5.2.

As you can see the volume bars are not visible on the chart because values are too small while y-axis for volume covers an unreasonably high numeric range and has only a small height of the chart assigned.

I want either:

  1. more reasonable overall range allocation for the volume in the secondary y-axis
  2. ability of increase display height for the secondary (volume) y-axis

Looking at it further, probably the problem isn’t the y-axis range but simply that the volume bars disappear if time range is too high?

after slightly zooming in:

(Btw. I also encountered an evil bug with the version from master where the whole chart disappears if the legend is enabled and one needs to hide it but this is something else than this problem. So just mentioning it if someone is hit by the same thing)

Probly if calculated pixel width of the volume bars is less than 1 it doesn’t appear or something like that? How to fix this? Something should be displayed in this case too when it’s possible to render price chart above (where each point is probly also <1px wide in this case).

Welcome @clime7

Can you try this plugin in grafana and see if it does better

Thanks, I will try it…