Bar gauge automatic scale not works

Hello,

I’m on Grafana v8.1.3

From an ELS database I try to do a “Bar gauge”, and … that works, but the automatic Scale fail:
grafa2

Like you see, the 34, 56 and 97 are on the same level.

Of course, If I add the “max” at 100, it’s ok.

kiba3

But tomorow I will have 150 or maybe 1000 on value … So I cant use manual scale

So do you think it’s possible to fix that ?

Thank you.

Hi @arethusa

Have you tried the new transformation, Config from Query results? That should be able to set min and max dynamically from the values returned by a query:

1 Like

Hello @mattabrams

Thank you for your time. I read the documentation, however, I don’t understand what I have to do.

In this configuration, the “Standard options” “Max” is “Auto” so I have the problem previously explain.

I have to find an other option ?

Thank you.

I found options Transform^^

I try to do some test, but nothing works.

I will try to find an other solution.

Thank you.

I would also check out these related issues in the repo: