Avoid zoom in on other panels

I did quite some search and did not find the answer. Is there a way to zoom in only on the panel that I select from the dashboard? Right now, whenever I zoom in on the dashboard, all other panels will also change to the same time interval as the panel that I select, which is very frustrating. Because other panels have different sensor arrival times, when I observe one sensor behavior, the other panels could look empty or no sensor information due to change of time interval from the panel that I select, which makes the whole dashboard look bad.
For example, the bottom panel looks empty (no data), which has data at the other time interval.

This part of the panel looks even worse, all no data :rofl:


Is there a way to fix the time interval on other panels? I tried to fix them using fixed query, but when I select and observe another panel from the Dashboard area, then they change again.

Hi,

Did you try relative time filter in your queries ?

Good Luck

Yes I tried the relative time filter. The other panels still change if I zoom in at the panel in the Dashboard section. :rofl:

Is there an option from Grafana not doing this?

Hi,

You can check this thread, using relative time and timeshift :slight_smile:

Hope it helps.

Good Luck