Anonymous Authentification in a Docker Container

I am using the official grafana docker

I want to set Grafana to Anonymous Authentification

As per the Grafana documentation page, I can change the grafana.ini using the syntax ’ GF_<SectionName>_<KeyName>
I tried both

GF_auth_anonymous=true

and

GF_auth_anonymous_enabled=true

but without any success.

Can some body tel me how to enable Anonymous Authentification in a Docker Container?

Try:

GF_AUTH_ANONYMOUS_ENABLED=true

Thanks Jangaraj
It works
IT seems that all letters should be capital letters

Sorry to resurrect an old thread – But GF_AUTH_ANONYMOUS_ENABLED=true is not working for me within docker. the default.ini in the docker container still shows the setting as false, even after a recreate.

Any ideas? Has this changed? Can’t find anything in the documentation further than this.

You should pass GF_AUTH_ANONYMOUS_ENABLED=true
as Docker Environment variable