Zabbix plugin tcp timeout after Grafana upgrade to latest version


I was running Grafana v7.01 with the Zabbix plugin 3.12.4. No issues here. i could reach the Zabbix API succesfully.

I then upgraded Grafana to the vert latest version v10.4, and updated the Zabbix plugin to it’s latest release v4.4.6.

Somehow when i test the data sources i’m ending with a tcp timeout.

i tried to even lower the Zabbix plugin version, but the error persisted. I even changed the OS from CentOS7 to Ubuntu LTS but i still see the problem.

What could have changed to get this error?

To connect to this Zabbix instance i don’t use any authentication, just a user and password for the API.

Software versions

|Grafana|Zabbix|Grafana-Zabbix Plugin|
|10.4 |5.4.4 |4.4.6 |

Thanks for taking the time to read through this!



Hello Matthew.
You are running a very old version of Grafana and plugins, and upgrading to the latest versions all at once may actually stop some features from working.

In this case, I would recommend performing the upgrade in parts, try upgrading first to version 8 of grafana and an older version of the plugin. Check if everything went well and upgrade to a newer version again.

Do not update directly to the latest version, I have had the same error that occurred with you.

Hi Bernando,

Thanks for the reply!

i have found the issue. Towards this Zabbix there was never a routing in place directly from Grafana. Instead it was working via browser method utilizing my computer’s IP address rather than Grafana’s.
Since the upgrade, it seems Grafana removed the browser option, so we needed to place a routing between Grafana and Zabbix.

1 Like