Zabbix plugin query editor won't display

  • What Grafana version and what operating system are you using?

Grafana: Version 8.3.6 (commit: bf8766bbf2, branch: HEAD)
OS: CentOS 8 Stream

  • What are you trying to achieve?

Create new panel in dashboard using Zabbix plugin.

  • What happened?

Query editor from Zabbix plugin doesn’t appear.

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.

There’s an error in main log (/var/log/grafana/grafana.log):
t=2022-02-11T14:29:03+0300 lvl=eror msg=“Plugin file not found” logger=context userId=1 orgId=1 uname=admin error=“open /var/lib/grafana/plugins/alexanderzobnin-zabbix-app/datasource-zabbix/datasource-zabbix/partials/query.editor.html: no such file or directory”

I assume there’s an error in the datasource path: “datasource-zabbix” is duplicated, it should be “/var/lib/grafana/plugins/alexanderzobnin-zabbix-app/datasource-zabbix/partials/query.editor.html”. Not sure whether it’s Grafana problem, or the plugin itself. It worked before (like 2-3 weeks ago), I’ve noticed it today.

I’ve tried reinstalling the plugin and datasource, but it didn’t help.

1 Like

I’m seeing this issue myself.

This is a third-party plugin, so I would report the issue in the official GH repo:

Yeah, the issue is there:

Tried different solutions, creating symlinks in the filesystem - doesn’t help. Sometimes you just delete and reinstall it few times, press “Update” in plugin’s Config tab and it’s magically fixes itself.

1 Like