Cannot edit Query with Zabbix as datasource

Hi everyone, I’m running Grafana inside a Docker container, already installed the Zabbix plugin (PLUGIN) and successfully connected the datasource. However, when adding items to the dashboard I cannot edit query to display data on the panel.

What am I missing?

1 Like

me too
After upgrading to version 8.3.2, this happened, the dashboard shows no problem!

I was on 8.3.1 version inside docker, I made a new container with the 8.2.0 oss version and now it’s working, same 4.2.4 version of the plugin.
Probably something is wrong with the latest version

I had the same problem. In my case, I manually reinstalled the zabbix plugin for grafana from this site:

with this command:
grafana-cli plugins install alexanderzobnin-zabbix-app

This solved my problem

Same link on my first post, with the same method throught the grafana cli. On which version were you having the problem?

Hello,

Does anyone have an update for this issue? I have same problem with
Grafana v8.3.1 and zabbix plugin 4.2.4. Cannot edit or create any new items.

I all ready tried to reinstall it with:
grafana-cli plugins install alexanderzobnin-zabbix-app

But no help here.

Br,
Jarkko

Hello all,

Does anyone have an update for this issue?

-jarkko

Roll back to a previous version of Grafana if you can. That worked for me

Hi,

Roll back to a previous version of Grafana
Unfortunately this is not a good option. I want to keep this in the latest version so that security is up to date. Maybe I have to just wait for the next version if this is fixed in it…

Hi,

If anyone can solve this problem without going through the roolback

Regards,

Hi,
I’ve the same problem.
I solved this temporarly in this way:
I’ve created an subfolder “datasource-zabbix” under “/var/lib/grafana/plugins/alexanderzobnin-zabbix-app/datasource-zabbix” and than a symbolic-link to partials:
ln -s /var/lib/grafana/plugins/alexanderzobnin-zabbix-app/datasource-zabbix/partials partials

for me i’ts working

1 Like

Hello, has anyone updated to Grafana 8.3.6 if problem still exist?
I wouldn’t want to change the file structure because a future Grafana update will change this back…

That really worked! Thank you!