Windows 2016 and C:\grafana\bin>grafana-server.exe not working

I believe I have configured all the required items for Grafana, but when I try to start the exe nothing happens.
Server is Windows 2016

From admin command prompt, when I run the command, it returns to the command prompt and then when I run the tasklist command, there is no grafana task or process, and the web site does not work.


C:\Grafana\bin>tasklist /SVC

Image Name PID Services
========================= ======== ============================================
ApplicationFrameHost.exe 5856 N/A
cmd.exe 5480 N/A
conhost.exe 4328 N/A
csrss.exe 2028 N/A
csrss.exe 2060 N/A
csrss.exe 396 N/A
dllhost.exe 2612 COMSysApp
dwm.exe 3768 N/A
dwm.exe 4460 N/A
explorer.exe 4872 N/A
lfsvc, ProfSvc, Schedule, SENS, SessionEnv,
LogonUI.exe 4820 N/A
lsass.exe 624 KeyIso, Netlogon, SamSs, VaultSvc
mmc.exe 20688 N/A
mmc.exe 3504 N/A
msdtc.exe 2808 MSDTC
MsMpEng.exe 1200 WinDefend
mysqld.exe 5916 MySQL57
NisSrv.exe 3112 WdNisSvc
NlaSvc, WinRM
notepad.exe 6820 N/A
nsi, W32Time, WinHttpAutoProxySvc
PlugPlay, Power, SystemEventsBroker
rdpclip.exe 1248 N/A
regedit.exe 5864 N/A
RuntimeBroker.exe 3564 N/A
SearchUI.exe 2388 N/A
ServerManager.exe 632 N/A
services.exe 616 N/A
ShellExperienceHost.exe 1304 N/A
ShellHWDetection, Themes, UserManager,
sihost.exe 580 N/A
smss.exe 316 N/A
snmp.exe 1984 SNMP
spoolsv.exe 1840 Spooler
svchost.exe 1064 CryptSvc, Dnscache, LanmanWorkstation,
svchost.exe 1180 BFE, CoreMessagingRegistrar, DPS, MpsSvc
svchost.exe 1204 LanmanServer
svchost.exe 1268 CertPropSvc, gpsvc, IKEEXT, iphlpsvc,
svchost.exe 1460 Wcmsvc
svchost.exe 1584 PolicyAgent
svchost.exe 1992 StateRepository, tiledatamodelsvc
svchost.exe 2016 DiagTrack
svchost.exe 352 Dhcp, EventLog, lmhosts, TimeBrokerSvc
svchost.exe 360 CDPSvc, EventSystem, FontCache, netprofm,
svchost.exe 4672 SSDPSRV
svchost.exe 608 CDPUserSvc_c0ac7, OneSyncSvc_c0ac7
svchost.exe 728 BrokerInfrastructure, DcomLaunch, LSM,
svchost.exe 792 RpcEptMapper, RpcSs
svchost.exe 916 TermService
svchost.exe 964 NcbService, PcaSvc, ScDeviceEnum, TrkWks,
System 4 N/A
System Idle Process 0 N/A
taskhostw.exe 476 N/A
tasklist.exe 17496 N/A
Taskmgr.exe 11800 N/A
UALSVC, UmRdpService, wudfsvc
VGAuthService.exe 1976 VGAuthService
vmacthlp.exe 1072 VMware Physical Disk Helper Service
vmtoolsd.exe 2000 VMTools
vmtoolsd.exe 5704 N/A
wininit.exe 468 N/A
winlogon.exe 5032 N/A
winlogon.exe 932 N/A
Winmgmt, WpnService
WmiPrvSE.exe 2752 N/A

I have posted configuration details here when I first thought it was an nssm issue.

Got it working - see my other post.

I am also using grafana on a windows server and I have run into some of the same issues you have. Here are some things I have learned that may help you.

  1. When using the CLI (command line interface) in command you have to reference the path for the cli interface, then put a space between that and the commands you are wanting to run with the cli. Also if you can open the file location in windows you can drag and drop the cli application into the command window and it will automatically insert the first part of the syntax to reference the command line so you only have to type the command in each time.

  2. in windows when running a command using the graf crunch cli you must always reference the default location for the plugins directory with every command you enter or they will fail. I have included example syntax here to help clarify what I am explaining.

(this command syntax was what I had to run to try and install the boomtable plug in. I should note that this was not successful for me but when running the command I do nopt get an unrecognized command error.)

"C:\Users\admin>D:\AdRem\GrafCrunch\bin\grafana-cli.exe --pluginsDir "D:\AdRem\Gr

afCrunch\grafana\data\plugins" plugins install grafana-cli plugins install yesor