Grafana service - Paused status

I have created a nssm service for grafana 5.1.4. I was able to create the service successfully but when tried to start the service, it’s going to ‘Paused’ status automatically.

the following warning popup is shown :

Windows could not start Grafana service on local computer. The service did not return an error. this could be internal service or windows error

I checked with our IT helpdesk but no resolution and event logs shows the following warning message

Grafana service ran for less than 1500 milliseconds and restart will be delayed by 25000 milliseconds
Program c\grafana\bin\grafana-server.exe for service grafana exited with return code 1

can anyone put some light on how to troubleshoot this issue or possible checks I am missing. I tried the same with Grafana5.2.2 but no luck.

Hi, I have the similar problem. I can run it stand alone but not as a Service via NSSM.
After installing the service and start… it just fails, goes to pause mode. I’m using grafana 5.2.4 (latest version as of October 2018)