Variables using dates are converted to unixtime

  • What Grafana version and what operating system are you using? Grafana 8.0.6 Centos 7.9

  • What are you trying to achieve? Have grafana not change my results

  • How are you trying to achieve it?

  • What happened? Grafana converts variable results from a date to unixtime by itself

  • What did you expect to happen? It not to do that

  • Can you copy/paste the configuration(s) that you are having problems with?
    In a Table Panel
    SELECT date from sites_config where router_desc = “router”
    Returns
    2020-09-21 09:14:01
    2020-09-25 20:37:24

As a Variable same SQL returns
1628037216000
1626309174000

This worked as expected in Grafana 7.1.5

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.

  • Did you follow any online instructions? If so, what is the URL?

In Grafana 8 there should be overrides and transformations that you can use to either change the unit appearance or set the data type. Might be helpful to the community if you shared a screenshot of your table and tried to describe what you would like to change :+1:

Had to go back to grafana 7.5, so I don’t have a screenshot. Transformations don’t work on variables in a templated dashboard.

Was there a solution to this?

This topic was automatically closed after 365 days. New replies are no longer allowed.