Using ElasticSearch on Grafana 5.4.2

I installed Grafana 5.4.2 on Ubuntu Linux, where I also have ElasticSearch setup for Grafana

I verified I can get the index file, after adding data source using step from http://docs.grafana.org/features/datasources/elasticsearch/

elktest@ELKServer:~$ curl -XGET ‘localhost:9200/_cat/indices?v&pretty’
health status index uuid pri rep docs.count docs.deleted store.size pri.store.size
green open .monitoring-es-6-2018.12.18 hMXOgfyqQlGl_6GbP-TCWg 1 0 203774 2321 129.9mb 129.9mb
yellow open filebeat-6.5.1-2018.12.01 7S2krSOhRb6rYDqcBbSAkQ 3 1 1022467 0 151.2mb 151.2mb
yellow open filebeat-6.5.1-2018.12.15 IoKxEP24STCasdp-eWofqw 3 1 177333 0 34.6mb 34.6mb
green open .monitoring-es-6-2018.12.15 _VNgGsoUTPKaAkISck-xfg 1 0 398739 2509 236.2mb 236.2mb

But I keep getting this error in the Settings page after clicking “Save & Test” button

“no handler found for uri [/fi12/19/20183b3pmt-6.5.1-2018.12.15/_mapping] and method [GET]”

Could you tell me what I have missed and any suggestions on how to solve this problem

Thanks,
Samuel

Hi @stckwok,

What version of Elasticsearch are you running and does it match the version in the Data Source configuration (under section “Elasticsearch details”)?

Hi Alex,
I am using Version: 6.5.1 for Elasticsearch. Grafana is able to recognize version 6.5.1 when I click Configuration -> Data Sources.

If this version is not compatible with Grafana 5.4.2, could you tell me which Grafana version should I use?

The error message shows :
“no handler found for uri [/fi12/19/20183b3pmt-6.5.1-2018.12.15/_mapping] and method [GET]”

It seems that URI is being read incorrectly by Grafana.
Is there any log file I should look at to find out why this is incorrect?

Thanks again
BR,
Samuel

Hi @stckwok,

In your datasource configuration screenshot, I notice “Version” is set to ‘5.x’. Can you try setting it to ‘6.0+’?

I challenge the same issue, have you resolved?

(tested with multiple possible options (like ES version, etc.). ES is green state. (6x ES, latest grafana, possibly bleading edge)

Your index name should be configured to filebeat-6.5.1-[YYYY.MM.DD] and the pattern should be daily.

I got the same problem.
my es is 7.5.1
my grafana is * v6.5.2

my index name is “filebeat-7.5.1-2020.12.11”

if set to

it is ok.

but if i set to

why?..

Try this:

Index name: filebeat-*     Pattern: no pattern

It will be read all index with prefix filebeat-