"Not Found" when adding elastic cloud elasticsearch source


I just discovered Grafana, looks very promising for what I’m looking to do (user based dashboards and mobile visualizations)
I’ve setup a free cloud account and tried to add my first elasticsearch source:

my server url is https://b8dxxxxxxxxxxxxxxxxxxxxxxx.ap-southeast-2.aws.found.io:9243

I tried with version 5.x, 5.6+
I tried with @timestamp, timestamp

Still got “Not Found” errors, in the network debug, it’s when trying to proxy the get _mapping request.

Any light on that ?


anyone having this issue ?

Too me it seems like index specified does not exist. Please include details of the failed requests like request and response details.


I am having similar issue, trying to add Elasticsearch as datasource but keep getting ‘no such index[index name]’. And what’s strange, index name, is different from the given one. Example: no such index[cu0to03r], when the given Index name is customer.

Here is from /var/log/grafana/grafana.log indicates the same:

t=2019-04-17T00:06:47-0700 lvl=info msg=“Request Completed” logger=context userId=1 orgId=1 uname=admin method=GET path=/api/datasources/proxy/4/cu0to03r/_mapping status=404 remote_addr=xx.xx.xx.xx time_ms=16 size=162 referer=http://xx.xx.xx.xx/grafana/datasources/edit/4/

Grafana v6.1.3 (commit: 9504db8)
Elasticsearch “lucene_version” : “8.0.0”

@jreyestmo seems you’re using Elasticsearch v7 (given lucene version) which is not yet supported in Grafana. But there are ongoing work and it will hopefully be included in next stable release.