Upgraded Grafana, now can't reference web files behind symlink / symbolic link. Any solution?

Previously on older (v7) versions of Grafana I could put images into the Grafana public directory and display them on my dashboards. This worked for images in the public directory AND for images behind a symbolic link/symlink in the public directory.

Is there a config change I can make to allow symbolic links again? Or an alternative solution?

But now in v9.0.1 it seems something has changed and images behind symlink/symbolic link cannot be shown - Grafana gives a 404 error.

  • What Grafana version and what operating system are you using?
    Grafana v9.0.1 installed (.deb) on Ubuntu

  • What are you trying to achieve?
    Show images on my Grafana dashboards.

  • How are you trying to achieve it?

Case 1: Copy an image here:
and reference it using URL:

Case 2: Copy an image here:
and reference it using URL:

  • What happened?
    On older (v7) Grafana both case 1 and case 2 worked fine.
    On v9.0.1 Grafana only case 1 works. Case 2 now gives 404 error.