Update flashes - distracting

Hi.

I’m creating some real-time displays in Grafana, by which I mean updates once per second.

So far, this is working well (neither browser nor server seem stressed by this).

However, every panel that I create in Grafana’s dashboard gets little circular “flash” in the top right hand corner when it updates, and with updates happening once per second, on several panels on a big screen, this is pretty distracting.

How can I turn off these update flashes, and simply have the numbers / graphs update quietly from their previous values / display?

Thanks,

Antony.

Does no-one have an idea about this?

Am I the first person to find these update flashes rather distracting?

I tried that out, definitely distracting. Maybe file a feature request to suppress the “updating” icon for intervals less than 5 seconds? Even at 5 seconds it is fairly distracting.

An url param would work as well vs trying to store the setting in a user profile.

I tried that out, definitely distracting.

Thanks for the confirmation. I wonder if I’m the only person using Grafana for
“really quite real-time stuff” like this.

Maybe file a feature request

How / where is the best way to do that please?

to suppress the “updating” icon for intervals less than 5 seconds? Even at
5 seconds it is fairly distracting.

I’d like to see it as an additional option next to the time range and refresh
interval selections - just a tickbox saying “update indications on/off”.

An url param would work as well vs trying to store the setting in a user
profile.

I’ll let the developers consider that level of detail.

Thanks,

Antony.

You can create a new issue on https://github.com/grafana/grafana to suggest a feature. This should be easy to implement.