Unable to upgrade Grafana from 8.3.5 to 9.3

  • What Grafana version and what operating system are you using?
    Current version on Ubuntu - 8.3.5

  • What are you trying to achieve?
    Need to test Phlare , hence trying to upgrade as its not supported on the current version that I have

  • How are you trying to achieve it?
    I have already installed and configured Phlare on Ubuntu, its says ready and running on the port 4100, however can’t see the Datasource on Grafana

  • What happened?
    Reference ticket : Unable to get Grafana Phlare datasource

  • What did you expect to happen?
    Expected to see Phlare datasource and monitor

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.
    No errors received

  • Did you follow any online instructions? If so, what is the URL?
    I referred this article - Getting started with Grafana Phlare - Getting started with Grafana Phlare - YouTube

Hi @vgmanasa24,

There was recently a similar question asked on our GitHub page. Please follow it as it explains how to get the Phlare in the newest Grafana version.

I hope this helps.

@usmanahmad I had followed that, but I still can’t get it upgraded from 8.3.5 to 9.3 , I don’t get errors, but after restart the grafana server and when i check the version its still the same.

sudo dpkg -i grafana_9.3.0~87537pre_amd64.deb
(Reading database … 256144 files and directories currently installed.)
Preparing to unpack grafana_9.3.0~87537pre_amd64.deb …
Unpacking grafana (9.3.0~87537pre) over (9.3.0~87537pre) …
Replaced by files in installed package grafana-enterprise (8.3.5) …
Setting up grafana (9.3.0~87537pre) …
Restarting grafana-server service… OK
Processing triggers for systemd (237-3ubuntu10.56) …
Processing triggers for ureadahead (0.100.0-21) …

Hi @vgmanasa24,

Just to understand better. you have not yet upgraded your Grafana server (still using ver. 8.5.3) but somehow have Phlare installed (as running on port 4100)?

Yes correct @usmanahmad

I also tried on my personal laptop, I have installed 9.3 pre version there and installed & configured Phlare , but still not seem to show up under Datasources. I did not receive any errors, the job was syncing and the service status is ready when checked. Please advice if I have missed anything

Hi @vgmanasa24,

Thanks for the reply.

So, I tried to test it out on my VM while using CentOS and it seems that Phlare is available in the Nightly-build version (grafana-9.4.0~89154pre-1).

Once it got installed I had to do one extra step i.e. to enable it from the configuration file. For that, I went into /etc/grafana/grafana.ini and under the section of feature_toggles enabled phlare i.e.

[feature_toggles]
enable = flameGraph

Then I restarted grafana and once I search in the data sources, it was available there.

I attached a screencast (open it in a new window as will be easier to zoom in and view more clearly)

phlare

I hope this helps else let us know your feedback.

Hey @usmanahmad
Sorry for late response.

Let me check installing the same version and keep you posted if any issues. Thank you very much!

Hey @usmanahmad ,

Still no luck for me , I have attached the screenshots for reference




Hi @vgmanasa24,

Thanks for testing and providing screenshots. I am really not sure why it does not work for you.

We would appreciate it if you can open a bug report about this in our official GitHub repository using this link.

Provide all the information (you can simply copy/paste your data + screenshot from here to there).

Also, 3 important things to mention there is that :

  1. What download you used (e.g. for Ubuntu, RedHat etc)
  2. Did you use the .deb, .rpm package for installation OR used the binary source i.e. .tar.gz?
  3. Please write your Grafana nightly build version by using the command on your server i.e.
[root@grafana ~]# grafana-server -v
Version 9.2.3 (commit: ec9c2ed029, branch: HEAD)

And paste the output there.

Lastly, paste the link of your Github issue here so I can also track it.

Thanks

Thank you very much for your support!

Here is the link : Need help with Grafana Phlare · Issue #59207 · grafana/grafana · GitHub