Unable to start grafana server on Mac using homebrew

I am using MacOS and have been trying to start Grafana using homebrew by issuing this command brew services start grafana
but I get an error that states:
Could not find domain for **
** Error: Failure while executing: /bin/launchctl enable gui/503/homebrew.mxcl.grafana

Wondering if anyone else have encountered this error and how to get past it? Thanks.

Can you start grafana with root account?

1 Like

Hello @thachnv92
I do not have root access to this Mac. But I do have administrator access which allows me to run/install anything on it.
And the same error message pops up when I run it even with admin access. Not sure what is causing it to fail.

Oh
I run command: sudo service grafana-server start on Linux.

1 Like

Thanks for this!
I prefixed sudo in front of my command and tried this:
sudo brew services start grafana
==> Successfully started grafana (label: homebrew.mxcl.grafana)
But it does not show which port it is running on?
Not sure if this is right because I don’t see anything running on localhost:3000 either

Excited ^^

You can check port listening in file config /usr/share/grafana/conf/
Ex: I use port 8080

image

2 Likes

It works! Thank you so so much for your help! :slight_smile:

WoW ^^
You can give me a few vote :smile:
Hihi

1 Like

@thachnv92 Sorry for my noob-ness, but where/how in the Grafana community do I give you votes? :slight_smile:

Just for fun :smile:
But you can see as image below :smiley:

image

1 Like

cat ~/Library/LaunchAgents/homebrew.mxcl.grafana.plist
vi /usr/local/etc/grafana/grafana.ini