Unable to launch Grafana login page

I tried using docker Grafana and everything working fine, after one or two weeks tried login and return error below. Tried different browser chrome, Edge, firefox, IE same issue, cleared cache with no luck. The only thing changed is Windows 10 upgrade (big one, 4 hour).

I tried on another Windows 10 machine with Edge (same version of the one I am using), the login page can be launched, seems server side is OK.

Please help here, thanks.

If you’re seeing this Grafana has failed to load its application files

  1. This could be caused by your reverse proxy settings.

  2. If you host grafana under subpath make sure your grafana.ini root_url setting includes subpath. If not using a reverse proxy make sure to set serve_from_sub_path to true.

  3. If you have a local dev build make sure you build frontend using: yarn start, yarn start:hot, or yarn build

  4. Sometimes restarting grafana-server can help

  5. Check if you are using a non-supported browser. For more information, refer to the list of supported browsers.

I tried create a docker on my PC locally, and it all working fine. So the browser should be OK.

The network should be no block as no firewall in between. It seems to me the grafana server is blocking my PC access. Please advise here. thanks.