Unable to import HAR files into the new k6 cloud version


Previously, I was able to import HAR files into k6 cloud and view the script mode.

But now I am unable to import it with the new k6 cloud version released (as of July 14, 2021)

Note that this was okay from the previous versions.

Please see below for the actual behavior on the latest version:

1. Importing HAR file directly from ‘Request’ tab panel.
Result: After importing, nothing happened.

2. Importing HAR file from ‘Create Test from Script’
Result: After importing, an error was displayed → * Invalid request postData (1): prohibited for GET request

I also tried importing my old HAR files that were working previously if I imported it in k6, but now shows same error/issue also.

Kindly check this out or if there is anything I need to do on my end. All of my test builds were via HAR files. So I’m kinda in big trouble for this case.

Thank you so much!

Thanks for reporting this, we’re investigating the issue! :bowing_man:

1 Like

We have released a new version of the k6 cloud app (v1.0.1) where this has been resolved. Please check it out and see if your HAR file(s) can be imported now.

1 Like

Hi! I believe it is now working okay and I can import HAR files already. Thanks for the sudden/quick fix as this is a very crucial functionality. Thank you so much!