Ubuntu 18.04 Installation Worked... Then Not Working Days Later after Restart

Did the inital install on Ubunto setting up mysql as backend.

I set the database name in garfana.ini to “architect”. there was no schema named architect in the database. Wasn’t sure i was supposed to create it before hand.

Everything came up and looked good. I added a couple of data sources, MySql Schema’s , one local one remote. Added some dashboards to each. Added some users.

Went to add carpet plot plugin and the service wouldn’t restart. I removed the carpet plot plugin same results. Failed with Exit-code.

Looked at var/log/grafana logs and saw it couldn’t find a schema named architect. Reviewed docs tried changing back to the default in the ini: grafana. No joy. Wouldn’t start,couldn’t find grafana.

Changed the ini back to architect and created an empty scema in my mysql server called architect.

Restarts fine, didn’t ask me to login or change password. I am in as admin. My dashboards and created users are all gone.

  1. Can I get any of my dashboards back?
  2. Did I miss a step in the install guides?
    If yes, what was that step?
  3. Other I was supposed to do that wasn’t documented or readily findable?

thanks,
Al

Maybe you did not restart the grafana-server when you switch to mysql so the first dashboards and users was created in grafana’s sqlite3 db, check in /var/lib/grafana/ for a file named garfana.db

I think you’re right. There is a non-trivial sized grafana.db. My bad. I do now see the schema created and fully populated in my MySQL database. My bad.

Thanks for the response.