Transform data: Binary Operation (/) is not working?

I am trying to divide

by

using the Transfoirm data Option and later again multiplying the output by 100 to obtain the percentage value (shown in the image below), but it is not working. Please note that the first series of data is weekly and the second series is Quarterly. How should I process the data so that the division would work?

try using the convert field type transformation and convert the filed types to numeric before doing the calculations

@sowdenraymond problem again, the calculation only worked half-way through and not up to the latest date (end of 2023). Please see the graph:

What is happening?

can you show a table view of your data at around that point please?

@sowdenraymond it is showing NaN to date, then how is it calculating the half?

I have attached the transform settings here as well.

Please note that the numerator is in weekly intervals and the denominator is in Quarterly intervals. So maybe dates are not matching, and interpolated data can be used for calculation by keeping the Quarterly points fixed and interpolating the other weekly data? If so, how?

whats does your data look like before the transforms?

@sowdenraymond here is what it looks like: the red column is weekly data and the green column is quarterly data. The date column has data in daily order though.

Is the NaN happening because of the empty cell division by empty cell? If so, then is there a way to filter-in only the rows that have data in both cells?

yeah its’ NaN’ing coz of divide by zero.

you can use a filter data by values transformation to exclude null values

@sowdenraymond I tried filter in transformation tab, but it’s going to be applied to the whole data set??? I only need the filter to be applied to those two specific column’s data, that too only when dividing. Is there a way to achieve that?

you can configure the filters at a field level
image

@sowdenraymond still not working. I am lost, any help? I have used the column name in the Field where you have “Tablespace used” selected.