TLS skip verify for generic OAuth

Hi,

I have KeyCloak identity server that is running with non-production certificate so far. I would like to connect Grafana’s OAuth to it but it complains because of TLS verification. I have found there is a flag to overcome it.

I have set GF_AUTH_GENERIC_OAUTH_TLS_SKIP_VERIFY_INSECURE=true but it seems the variable is not taken at the beginning, other generic OAuth variables are.

I use following version:

t=2018-07-28T07:22:10+0000 lvl=info msg="Starting Grafana" logger=server version=5.2.2 commit=aeaf7b2 compiled=2018-07-25T11:17:28+0000

I can also see multiple values being overriden:

t=2018-07-28T07:22:10+0000 lvl=info msg="Config overridden from Environment variable" logger=settings var="GF_AUTH_GENERIC_OAUTH_ENABLED=true"

Is there a bug or I am doing something wrong?

Thank you for help.

I guess, it’s not implemented. Did you find it in the documentation?

I found it in the code :slight_smile: And it was merged in October 2017…


So probably I am missing something…

You are right. It looks like a bug. Config option is missing in conf/defaults.ini, so you can’t override it with env variable.

if that is the only thing, I can create pull request for that, but I am not a Go developer yet :slight_smile: I will report an issue along.