The Grafana home icon redirects to the login form despite enabling anonymous access

  • What Grafana version and what operating system are you using?
    Grafana 9.2.5
    Redhat 8.4

  • What are you trying to achieve?
    Redirect to the home dashboard when pushing the Home button

  • How are you trying to achieve it?

  1. Enable anonymous access (grafana.ini)
  2. Select Home Dashboard for the Organization (UI β†’ preferences)
  • What happened?
    Every time a user push home button get redirected to login form (https://grafana.xxxxx/login)

  • What did you expect to happen?
    A redirection to home dashboard

  • Can you copy/paste the configuration(s) that you are having problems with?

[auth.anonymous]
enabled = true
org_name = "myOrg"
org_role = Viewer
[auth]
disblable_login_form=true
  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.
    No

  • Did you follow any online instructions? If so, what is the URL?
    No

We have recently updated from 8.4.4 to 9.2.5 and noticed that pushing the Grafana home icon redirects to /login instead of the Home dashboard.
Every time a user wants to return to the home dashboard they only have to push de Grafana home icon, but with the new version, this is not working.

What configuration are we missing?

Any help would be appreciated!

The same thing happens in the Grafana Playground https://play.grafana.org/d/000000012/grafana-play-home?orgId=1.
After clicking the Home button, redirect to the login form.
And it’s the same version we are using (9.2.5).

It was not the behavior in Grafana 8.4.x. Is there any configuration we could apply to avoid this redirection?

Thanks.