Table panel does not show data

Hi There,

Am working on building dashboards in Grafana using Elastic Search data source. One of the panels am using is a table panel where the condition is to select all servers which have a specific beat.hostname entry. All is good but one thing am hoping to do is to make sure that all servers for the application would show up in that table even when Elastic Search doesn’t have any data for the time period selected. (For example assume there are no entries from a server between 9 to 9:15 and if I set the dashboard time to 9 to 9:10; since there is no data for that server in that time frame, it automatically falls off the table)

Can someone please let me know if there is a way I can make that show up? Appreciate your time and help in-advance.

Thanks,

CK

Did you try setting “Min Doc Count” to 0?

Reference: https://www.elastic.co/guide/en/elasticsearch/guide/current/_returning_empty_buckets.html

Hi Daniellee,

I tried doing that inside table panel config in “Group By” metric but somehow once I click away from the cell after setting the value 0, it changes back to 1.

Also is there a way to set those extended bounds parameter from with-in Grafana or is it something that’s got to defined inside of ES?

Thanks,

CK

Did you try and set it to the date histogram group by or another group by? I think it only works on the date histogram. You might want to combine it with a Display option “connected”, “null as zero” or “null” depending on how you want to visualize the gaps.

image

extended bounds parameters are set automatically by Grafana. You can see that by using the query explorer and looking at the raw query sent to Elasticsearch:

image

Thank you Danielle for sharing that info. Sure did learn something new today, but the grouping am using is using only hostname variable. Also validated that am able to set Min Doc Count to 0 when using date histogram. I will check to see if there is a way I can add date histogram into that query.

Appreciate the help sir :slight_smile: