State Timeline: how to NOT display the metric names

Recently upgraded grafana and discovered state timeline, so I am replacing the old custom plugin I was using to achieve the same visualization. I found one issue though with this new functionality, I couldn’t find a way to REMOVE the metric name that shows at the right of the graph, so that the time axis aligns with the other graphs in the dashboard.

This is what I mean:

I want to remove the “HVAC” legend at the LEFT of the state timeline, so that the time scale of the state timeline will align with all other graphs in the dashboard, like the one above

The old custom plugin I was using for the last few years (and that seems to have disappeared since I guess the functionality was added to Grafana core) had an option for this. I tried with a simple override like this one:


but it doesn’t accept a null value (it goes back to the metric name), and if I replace the display name with e.g. “-”, this doesn’t fix the time alignment with the other graphs, it’s like there is “space reserved for the metric name” to the left of the state timeline that remains regardless of the display name length.

I observed the same glitchy behavior and posted about it a few months ago. I also opened up a ticket with Grafana support but they could not offer a fix.