[SOLVED] Alert : no data?

Hi,

I would like to create some alerts on my grafana website, but I can’t achieve to do it :slight_smile:

as you can see, it says “No data”, even my query seems good (a point every 5min), and the alarm display well.

What am I doing wrong ?

Thanks

Nobody have this problem ?

I tried another dashboard and it’s the same

thanks

Object

firing:false

state:“no_data”

conditionEvals:“false = false”

timeMs:“9.599ms”

logs:Array[2]

0:Object

message:“Condition[0]: Query Result”

data:null

1:Object

message:“Condition: Eval: false, Query Returned No Series (reduced to null/no value)”

data:null

Hi @dureiken, can you also post how your query looks like?

Hi,
I have the same issue (Grafana v6.1.6 (commit: cf9cb45)).
Below you’ll find the request and the alert.

grafana_query

grafana_alert

Thanks for your help.

@zigobos In your example it seems like the issue is that your condition checks interval for which there really aren’t any data. The part query(A, 5m, now) means it will take last value from time range between now-5min and now and from your graph it looks like there is no data point since ~ 16:20. Try changing the interval to something like query(A, 5h, now-4h) or something like that so it hits the range when there are values. Though ideally to test the alerts you would do it on datasource which has some current values.

In @dureiken example it seems there should be data in the specified interval query(A, 1h, now-5m) but would be a good idea to look at the returned data from the query and check if there really are data points for that interval just to be sure.

2 Likes

Thanks for your help

I think the problem comes from UTC time

Because I’m UTC+2, and I can’t choose now -2h, now -3h for example.

Could I change it manually ?

edit : yes it works with 24h, now -1h

Thanks

@dureiken If you mean inside the query(), when you click on a param you can write the params value manually as it is a text input, you do not have to select it from the drop down menu. Though I am not sure if the timezone difference should create such problem.

ok it was that

with now-4h,now-2h it seems to work

thanks a lot

@aocenas Thank you, that’s ok now :+1:
@dureiken Thank you for hosting my post :wink:

Thank you for this answer! That was what I was doing wrong too.