SMTP requires user password?

I’m trying to setup SMTP for alerts and see the documentation says it requires the users password for email and was wondering why?

If it’s just sending an SMTP message and is allowed on our exchange server to do so, why does it require the users password to send that email? Or am I mistaken?

Config file looks like:

#################################### SMTP / Emailing ##########################
[smtp]
;enabled = true
;host = 10.10.10.10:25
;user = support@domain.com
“# If the password contains # or ; you have to wrap it with trippel quotes. Ex “””#password;"""
;password =
;cert_file =
;key_file =
;skip_verify = false
;from_address = grafana@domain.com
;from_name = Grafana

[emails]
;welcome_email_on_sign_up = false

Some SMTP servers require user/password authentication to send emails

I see, if I leave it blank and point it at our exchange server (which doesn’t require authentication if manually added to the connector) will it send?

1 Like

I have a similar issue where my SMTP server doesn’t require authentication so I’ve left the username/password blank but I still get an authentication error.

error=“gomail: could not send email 1: 530 5.7.1 Client was not authenticated”

Config file
[SMTP]
host = hostip:25
;user =
;password =
;cert_file =
;key_file =
skip_verify = true
from_address = address@from
from_name = from name
ehlo_identity =

The above worked in version 5.2 but have since moved to 6.2.5 and now it does not work anymore.

I’ve not tested on that version but have you tried leave user and password fields blank instead of commented?

So just removed the comment and left settings as below:

user =
password =

Restarted server, no change, still auth failure.

Note: I’m just doing a send test email from my notification channel and tailing my grafana log file.