Single Browser Session Limitation with Grafana Dashboard on Subpath Configuration

I am encountering a unique issue with Grafana where it seems to allow dashboard access from only one browser at a time when configured with a specific subpath.

Configuration Details (Anonymized):

  • Grafana INI Settings:
root_url= "%(protocol)s://%(domain)s/subpath"
serve_from_sub_path= true

Ingress Configuration for Grafana :

  • yamlCopy code
  enabled: true
  ingressClassName: nginx
  annotations: letsencrypt-prod
  path: /subpath/
    - secretName: grafana-tls-secret

Problem Description:

  • Accessing Grafana through the first browser works fine.
  • However, when trying to access the same dashboard from a second browser, it does not work.
  • Changing the subpath in the configuration allows access from the second browser but then blocks the first one.
  • It seems Grafana is restricting access to only one browser session per subpath.

I would appreciate any insights or solutions to this issue. Has anyone encountered a similar problem or can provide guidance on how to resolve this?

what does it mean?

I get this error page

Check network browser console, pls
What kind of errors are there and why requests are failing?

The console is showing this error:

Uncaught SyntaxError: Invalid or unexpected token

in the network I dont see any problem:

Blind guess: clear cookies, session/local storage.

I tried that actually, and the working browser stopped working as well :smiley:

Something is locking the session to one browser and disallowing any other requests from any other browser I am not sure what settings or configurations could cause this.

Note: connecting to it from the port forward command is working normally

kubectl port-forward svc/kube-prometheus-stack-grafana 3000:80 -n kube-prometheus-stack

Nope, I guess something is messing with cookies. You may use browser console and inspect cookies and their set requests, find what’s causing “Invalid or unexpected token”, check how official grafana helm chart configure ingress, replace ingress by LB service,…

ok found the solution finally here:

Cloudflare was the problem