Select nearest data point when cursor doesn't have any point behind

Hello, I wanted to know if it’s possible to have the data nearest to the cursor displayed instead of having nothing displayed when having the mouse between two data points.


I don’t believe that this is currently possible. Sorry!

I solved it by filling my data with none instead of null

1 Like

Filling my data with fill(none) instead of fill(null) always worked to solve this problem in the old Graph-Panel.
Unfortunately, with the new Time series-Panel this trick isn‘t working.
My outdoor temperature for example is only measured every five minutes. With fill(linear) it does work since the datasource is automatically creating points when there is no data, but then of course the nice new line-interpolations are not longer working since there is not longer any space between the points. So also not a final solution.
Any ideas how to solve it with the new Time series-Panel?

I have the same problem as you, I had to choose between having a decent tooltip and having the cool treshold-limited connections. In the end I opted out for the tooltip because there’s an open feature request to fix the treshold connection in absence of null values, so I’m hoping they do it fast.

1 Like

But is it planned?
For me it looks like the Time-series -Panel should now completely replace the Graph -Panel. In my opinion it really would be a downgrade if this tooltip stays as it actually is!

Hi all,
super interesting discussion.

Just to clarify: are we talking about the fill() function in influx?

Can you screenshot the two different behaviors or reproduce it on

Hello Matt!
Yup! We’re talking about the Influx fill() function!
Since I have no idea about which query I could make on play grafana org, I’ll suggest you an issue: #34542
Here leeoniya explained the null-value problem, plus if you look around the issue you’ll find some screenshots of what happens before-after null/none-filling.

1 Like

@knocks83 was faster, but here are some screenshots:

Old Graph-Panel with fill(none): Wherever I have the cursor, it will always show me a tooltip-value:

The new Time-series-panel with fill(none): When there is a data point at the cursor it will show a tooltip, but not when there is no data point at the cursor’s position:

It theoretically can be solved with using fill(linear), since points are automatically created if there is no data. Unfortunately, the cool new interpolation of course then is not working:

strangely, I find that switching the tooltip mode to all fixes this in many cases…

this PR might help things, too:

Good to know!
I just updated to the newest Grafana-version, however the problem remains.

still occurring with 8.1.2?

I can say that I see the same behavior with 8.1.2.

As indicated by @ mattabrams, switching from Single to All in the ToolTip mode shows that there must be some unexpected behavior, or at least inconsistent behavior between the two settings.

Here is a gif showing what ToolTip Mode Single vs All shows:

You can see that Single will only report data when you hover over a specific data point and All continuously shows the data when hovering, even when not directly on a data point. I’d expect that the behavior displayed with All is what would happen when using Single.