Screenshots in alerts

I have Grafana running in docker along with Renderer. I’ve enabled screenshots in the configuration via the environment variable.

      - GF_RENDERING_SERVER_URL=http://renderer:8081/render
      - GF_RENDERING_CALLBACK_URL=http://grafana:3000
      - GF_LOG_FILTERS=rendering:debug

I am unable to get alerts with screenshots. The alerts are linked to a dashboard and panel.

In the defaults.ini, the configuration still shows capture = false. Is it expected?

# Enable screenshots in notifications. You must have either installed the Grafana image rendering
# plugin, or set up Grafana to use a remote rendering service.
# For more information on configuration options, refer to [rendering].
capture = false

What else can I check to troubleshoot this issue?

I would check the troubleshooting instructions here.