Request is Forbidden While Importing JSON File

Hi Team,

I have deployed Grafana in Kubernetes with Azure AD enabled. My aim is to import the JSON file. while I am trying to import the JSON file its throwing Request Forbidden, not sure why I am getting this error. Could any one can help on this issue.

I have installed Grafana locally and there I tried to import the same JSON file it worked. But while trying in Kubernetes Secured URL its throwing Error. Not sure what is missing.

Note: I have created docker image from the github repository from Main branch and deployed to Kubernetes.
(GitHub - grafana/grafana: The open and composable observability and data visualization platform. Visualize metrics, logs, and traces from multiple sources like Prometheus, Loki, Elasticsearch, InfluxDB, Postgres and many more.)



Why not use the official docker ?

Is this install from github also?

@yosiasz Building from Source Code and using Docker Hub both are same only right, If we use from Source Code then directly we can modify the Configuration file and build it so that is so easy. So I am using from Source Code building and pushing image via Azure Devops Pipelines and then deploying it to Kubernetes.

Locally I downloaded the exe file and I tried.

1 Like

Error Screenshot attached.

So what is this json file you are trying to inport? Is it a dashboard from elsewhere ir from official grafana dashboard market place?

@yosiasz One of my team members developed dashboard from their system and they exported and provided the JSON file, while I am trying to import in deployed grafana URL its throwing error.

does their dashboard have some specific data sources you need to install?

That plugin I already installed then also getting the error.

@yosiasz any update on my query ?

What kind of system are they using compared to the grafana you are trying to import to? Version, Os etc

Could it be a permission issue?