Can't import dashboards ID

Hello,

When I want to download a dashboard via its ID, I get an ‘Unauthorized’ error.

In the console world, I have :

GET https://xt/api/gnet/dashboards/10000
[HTTP/3 401 Unauthorized 207ms]
GET
	https://x/api/gnet/dashboards/10000
État
401
Unauthorized

I’m using cloudflare on my grafana, could this be the cause?

Environment:

Grafana version: Grafana v8.1.5 (c725a42)
Data source type & version : Prometheus with browser access
OS Grafana is installed on: Kubernetes
User OS & Browser: Firefox 93

Which dashboards are you trying to import?

any of which does not work

Someone can help me ??

your title says import, but your post says download. Are you trying to import a pre-built dashboard from grafana.com into your grafana instance, or “download” one of your own dashboards?

When I want to import a dashboard via its ID retrieved from Dashboards | Grafana Labs I get the error I indicated in my first post

hmm, have you tried upgrading? You’re running grafana in K8s?

I’m running a personal instance on a vm behind cloudflare and it can import:

guessing this is maybe some networking config issue?

Yes I am in a kubernetes environment and I have the latest version of grafana

1 Like

Hello,

up, it’s still present

Hello,

up, it’s still present

@qdupuy If you are still encountering this issue then I would suggest making a GH issue? But I know that they will ask you for reproduction steps. Can you run your k8s environment in minikube to confirm that the issue is networking related, like Cloudflare as you suspect?

How are you deploying? I think the squads will want a yaml or something so they can deploy and reliably reproduce this issue. I would also try to troubleshoot and see if this is your cloudflare config.

I would also try upgrading to the newest Grafana version just to rule that out as well

Same error with my k3d cluster (minikube like)

I always update grafana