Problems after migrating version 8.3.6 to version 9.4.7

  • What Grafana version and what operating system are you using?
    Version 9.4.7 and red hat 8.7

  • What are you trying to achieve?
    that works correctly

  • How are you trying to achieve it?
    doing the corresponding migration steps as published in grafana

  • What happened?

  • What did you expect to happen?
    that is not happening

  • Can you copy/paste the configuration(s) that you are having problems with?

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.

  • Did you follow any online instructions? If so, what is the URL?
    Upgrade to Grafana v9.4 | Grafana documentation

I am having performance related issues since updating Grafana from version 8.3.6 to version 9.4.7 . I have several large dashboards, that have more than around 50 panels and about 10ish variables. These large dashboards are now taking a very long time to load, several minutes, making the user experience quite poor when they would take a few seconds to load on the previous version.

I am having performance problems since I upgraded Grafana from version 8.3.6 to version 9.4.7. I have several large dashboards, which have more than 50 panels and about 10 variables. These large dashboards now take a long time to load, several minutes, making the user experience quite poor when in the previous version they took a few seconds to load.
When I use the Chrome tool and analyse the old version I see that it takes very little time because it only loads about 3 MB but when I do the same test in version 9.4.7 I see that it exceeds 103 Mb and takes a lot of time leaving almost toasted to be able to move through the graphs of the graph panel.

The migration I did was as follows, I installed on a red hat 8.7 the Grafana 9.4.7 binary file and then I copied the Grafana 8.3.6 version database which is a sqlite and replacing it with the 9.4.7 one, I restarted the Grafana database and I already had all the dasbhoard from the 8.3.6 version in the 9.4.7 one.

Now when I move through the dashboard it takes a lot, as I said I have used the Chrome development tool and I notice that the information that loads is not the same in addition to the more modern version gives more errors and loads many errors, attached capture. can you tell me where Iā€™m wrong?

1 Like