Private plugin no longer loading after upgrading Grafana

I have a private plugin I created last year and now we are looking at upgrading from Grafana 8.3 to the latest 9.3.6. The plugin is no longer loaded when booting up Grafana and I’m not getting any errors in /var/log/grafana/grafana.log file. I’m facing the same problem even when just trying to upgrade to 8.5

I’m guessing this is going to be something really simple within my plugin that might be hard setting it to only work in a specific version but the only possibility I could find was the grafanaDependency. However that doesn’t seem to be the issue as mine is set like below and even if I hard set it to the version I’m using it’s still not loading.

    "dependencies": {
        "grafanaDependency": ">=8.3.0",
        "plugins": []
    }

grafana.ini

app_mode = development
plugins = /var/lib/grafana/plugins

Just as a side note the plugin is signed anyways so I don’t really need to be in development mode.

I also tried migrating to the latest @grafana/create-plugin which doesn’t seem to help either.

Does anyone have any ideas? Thanks

Does the signature (MANIFEST.txt) perhaps lack "manifestVersion": "2.0.0"? If so you’ll need to re-sign it since manifest of version 1.0.0 is no longer supported.

@mefraimsson It does have "manifestVersion": "2.0.0", unfortunately. I wish that was the solution :slight_smile:

@kvannorstrand try to run grafana locally in your computer and see the log when it initializes. if it is not loading your plugin you will see in the log information about trying to load it and why it loaded or did not. you can do this, for example, with docker it should be something like this:

... many messages
grafana-clock-panel  | logger=settings t=2023-02-06T13:25:27.391830762Z level=info msg="Path Plugins" path=/var/lib/grafana/plugins
... many more messages
grafana-clock-panel  | logger=plugin.loader t=2023-02-06T13:25:50.348689007Z level=info msg="Plugin registered" pluginID=input
grafana-clock-panel  | logger=plugin.signature.validator t=2023-02-06T13:25:50.349481813Z level=warn msg="Permitting unsigned plugin. This is not recommended" pluginID=grafana-clock-panel pluginDir=/var/lib/grafana/plugins/grafana-clock-panel
grafana-clock-panel  | logger=plugin.loader t=2023-02-06T13:25:50.349512351Z level=info msg="Plugin registered" pluginID=grafana-clock-panel

the previous log is what you get when you run yarn server in the grafana clock panel repository GitHub - grafana/clock-panel: Clock Panel Plugin for Grafana

We also require all plugin files to be part of the manifest. As earlier response suggested try to check the logs to find the problem.

@academo thank you! I ran it locally and was able to see more logs than I was finding in my remote VM. Turns out at some point the panel’s plugin.json id was removed so the plugin was failing to load. After adding back in the id it all loads fine and at first glance seems to be working. Thank you for jogging my brain on this!