Plugin loaded but not showing as data source

I am running Ubuntu 20.04.4
Grafana 8.4.6
and have installed the zabbix plugin.
In the logs i see that the plugin has registerd.

logger=settings t=2022-04-18T11:24:15.08-0500 lvl=info msg="Path Plugins" path=/var/lib/grafana/plugins
logger=settings t=2022-04-18T11:24:15.08-0500 lvl=info msg="Path Provisioning" path=/etc/grafana/provisioning
logger=settings t=2022-04-18T11:24:15.08-0500 lvl=info msg="App mode production"
logger=sqlstore t=2022-04-18T11:24:15.08-0500 lvl=info msg="Connecting to DB" dbtype=sqlite3
logger=migrator t=2022-04-18T11:24:15.1-0500 lvl=info msg="Starting DB migrations"
logger=migrator t=2022-04-18T11:24:15.11-0500 lvl=info msg="migrations completed" performed=0 skipped=381 duration=686.523┬Ás
logger=plugin.manager t=2022-04-18T11:24:15.14-0500 lvl=info msg="Plugin registered" pluginId=input
logger=plugin.manager t=2022-04-18T11:24:15.58-0500 lvl=info msg="Plugin registered" pluginId=alexanderzobnin-zabbix-datasource
logger=plugin.alexanderzobnin-zabbix-datasource t=2022-04-18T11:24:15.59-0500 lvl=info msg=Profiler enabled=false
logger=plugin.manager t=2022-04-18T11:24:15.59-0500 lvl=info msg="Plugin registered" pluginId=alexanderzobnin-zabbix-triggers-panel
logger=plugin.manager t=2022-04-18T11:24:15.59-0500 lvl=info msg="Plugin registered" pluginId=alexanderzobnin-zabbix-app

When i go to the grafana dashboard to add a source i do not see the zabbix plugin. Any suggestions of what else i can check or do?

I also see the plugin installed when i run the command grafana-cli plugins ls

grafana-cli plugins ls
installed plugins:
alexanderzobnin-zabbix-app @ 4.2.5

I am also having the same issue with oem plugin
The plugin was not visible. I changed allow_unsigned_plugin and then it started getting visible in plugins section.
However it is still not visible in data source section due to which i am failing to proceed. Kindly suggest.