Osisoft Plug-in DataSource connection with Grafana


I’ve tried connect to PI Server in my computer. But I don’t know how to access proxy settings. And In datasource configuration page, it give me an error like “HTTP Error Bad Gateway” or “HTTP Error Unauthorized”.

I am having the same problem. did you resolve it?

Sorry for returning late. Yes, I solved it. It’s been a while since I used Osisoft but I remember. Apart from the grafana settings, you need to choose Basic instead of Kerberos in the configuration database in Osisoft Pi. I’ve applied this setting before, but it didn’t work. Then when I reinstalled Osisoft and tried to reconnect Grafana and Osisoft I succeeded. I think the previous installation Osisoft was installed incorrectly.