Nginx configuration for grafana https request

I am trying to configurate a proxy in nginx.conf for grafana request. My request it will be like:
the request will work with https
and the request from which is being working is

my nginx.conf is:

 http {
      include       /etc/nginx/mime.types;
      default_type  application/octet-stream;

    log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

    access_log  /var/log/nginx/access.log  main;

    sendfile        on;
    #tcp_nopush     on;

    keepalive_timeout  65;

    #gzip  on;

    include /etc/nginx/conf.d/*.conf;
    server {
        listen 443 ssl http2 default_server;
        ssl_certificate "/etc/nginx/cert/cert.pem";
        ssl_certificate_key "/etc/nginx/cert/certkey.pem";
        ssl_prefer_server_ciphers on;
        root /usr/share/nginx/html;

		location /grafana/
		    proxy_pass https://localhost:3000/;
			proxy_set_header Host                 $http_host;
			proxy_set_header X-Real-IP            $remote_addr;
			proxy_set_header X-Forwarded-For      $proxy_add_x_forwarded_for;
			proxy_set_header X-Forwarded-Proto    "https";
        location / {

my grafana.ini is this:

# Protocol (http, https, h2, socket)
protocol = http

# The ip address to bind to, empty will bind to all interfaces
;http_addr =

# The http port  to use
http_port = 3000

# The public facing domain name used to access grafana from a browser
domain = localhost

# Redirect to correct domain if host header does not match domain
# Prevents DNS rebinding attacks
enforce_domain = true

# The full public facing url you use in browser, used for redirects and emails
# If you use reverse proxy and sub path specify full url (with sub path)
root_url = https://%(domain)s:%(http_port)s/grafana/

# Serve Grafana from subpath specified in `root_url` setting. By default it is set to `false` for compatibility reasons.
;serve_from_sub_path = true

# Log web requests
;router_logging = false

# the path relative working path
;static_root_path = public

# enable gzip
;enable_gzip = false

i cant find what is wrong because as that the proxy is not working,
as the request works with


but not with


I will be very gratefully if someone help me

best :slight_smile: