Loki logs shows in explorer but not in dashboard

I have Loki, Grafana & Promtail running on AWS EKS cluster. I am able to view logs form explorer but same query {namespace=“kube-system”} used in dashboard is not showing results. My requirement is to use dash board and alert rules to create alerts from application logs.

Also explorer shows Logs This datasource does not support full-range histograms. The graph is based on the logs seen in the response.

Thanks.

Hello @cspradeep there are couple of questions asked here. So:

I am able to view logs form explorer but same query {namespace=“kube-system”} used in dashboard is not showing results.

Are you using Logs Panel to visualise your logs? If you are running log query {namespace=“kube-system”}, you need to select Log panel visualisation to visualise logs.

My requirement is to use dash board and alert rules to create alerts from application logs.

You can create alerts only on metrics Loki queries, not logs queries. Metric queries | Grafana Labs e.g rate({namespace=“kube-system”}[1m]) (depending on what you want to alert on)

Also explorer shows Logs This datasource does not support full-range histograms. The graph is based on the logs seen in the response.

Full range histogram is a new feature in Grafana 8.3+, but it is still behind feature flag. You can learn more about this + how you enable it here Loki: Full range logs volume by ifrost · Pull Request #39327 · grafana/grafana · GitHub