Log10 doesn't work

Whenever I try using log10 in the timeseries panel the browser freezes for a moment and then the panel goes blank. My datasource is influxdb, and these are nearly identical queries to ones that worked on the graph(old) panel back when that was accessible.

When I look in the browsers console this pops up:

es.array.push.js:36 Uncaught RangeError: Invalid array length
at Array.push (es.array.push.js:36:12)
at Object.Sn [as splits] (uPlot.esm.js:1358:10)
at uPlot.esm.js:4085:38
at Array.forEach ()
at Mc (uPlot.esm.js:4050:8)
at rs (uPlot.esm.js:3129:24)
at tf (uPlot.esm.js:4340:4)

Anyone know what to do? Graph(old) used to work so well but ever since they deprecated it log10 has just had major issues…

Welcome @tomjmiletich

For the log10 function, are you using InfluxQL or Flux? And which version of Grafana?

Hi Grant,

I’m using Grafana v10.1.2 with InfluxQL. I tried Flux as well and it doesn’t work.

To be specific it’s setting the y-axis scale to Logarithmic with a base of 10 that isn’t working, logarithmic with base 2 works for some reason.

Edit: It seems it works fine for me when I have values above 1e-14, but when I go below 1e-14 the issue pops up. The data I’m working with typically trends between 1e-16 and 1e-12.