Local image not being uploaded to slack

I have an alert that is sending slack notifications. In grafana.ini I have set the provider to local so that the images of the panel are generated on the local filesystem.

When an alert gets sent in the logs the panel image is being generated and stored on the server but the image is not being shown in the slack message.

Is this a configuration issue? Why would this image not be added to the slack notification?


1 Like

Can you provide some more details on how you configured the slack notification?

If you want to include screenshots of the firing alerts in the Slack messages you have to configure either the external image destination in Grafana, or a bot integration via Slack Apps.

Thanks Daniel. Here is the notification channel screenshot

Then the grafana.ini

#The public facing domain name used to access grafana from a browser
domain =

#Used for uploading images to public servers so they can be included in slack/email messages.
#you can choose between (s3, webdav, gcs, azure_blob, local)
provider = local

Not sure what else I could do differently really
Thanks for your help


I have exactly the same problem.


@daniellee @danielgonzalez @mefraimsson Slack alert Image not being uploaded, no msg related to upload in logs(without external renderer) , tried with external grafana-image-renderer as container, getting log that image uploaded to localhostā€¦, as i have set external_imageā€¦provider = local in ini but no image in slack, please please help how to setup slack with image attachment

Very same problem in here with slack, not images being attached and also using
provider = local

grafana-server Version 7.2.1 (commit: 72a6c64532, branch: HEAD)
grafana-image-renderer @ 2.0.0
This is on a Linux2 Amazon

I fixed it by disabling the bot configuration in Grafana and installing the grafana-image-renderer.
You could check if PNGs are being generated at all, look in your Grafana data folder.
Iā€™m running Grafana 7.3.1.

Hi @basroovers
I just upgraded to Grafana 7.3.1.
I can confirm the plugin was installed and the PNG files are there. I am using the Slack plugin and I got all the boxes for the bot empty, so I guess my configuration should be similar to yours.
I am using using the local storage.