Loading page never ends

The Grafana application when opened on a local area network works perfectly. However when I try to open in an external network the page stays stuck in the loading screen (“Loading Grafana”) or fewtimes appears this error:

If you’re seeing this Grafana has failed to load its application files

This could be caused by your reverse proxy settings.

If you host grafana under subpath make sure your grafana.ini root_path setting includes subpath

If you have a local dev build make sure you build frontend using: npm run dev, npm run watch, or npm run build

Sometimes restarting grafana-server can help

My application is running on the following ip / port:
http://200.137.4.215:3000

I talked to the network administrator and asked for port 3000 to be open. Is there any other port I need to request to be opened?

Here is the log when I try to access over external network:

t=2019-01-23T15:54:02-0300 lvl=info msg=“Initializing HooksService” logger=server
t=2019-01-23T15:54:02-0300 lvl=info msg=“Initializing InternalMetricsService” logger=server
t=2019-01-23T15:54:02-0300 lvl=info msg=“Initializing CleanUpService” logger=server
t=2019-01-23T15:54:02-0300 lvl=info msg=“Initializing NotificationService” logger=server
t=2019-01-23T15:54:02-0300 lvl=info msg=“Initializing ProvisioningService” logger=server
t=2019-01-23T15:54:02-0300 lvl=info msg=“Initializing PluginManager” logger=server
t=2019-01-23T15:54:02-0300 lvl=info msg=“Starting plugin search” logger=plugins
t=2019-01-23T15:54:02-0300 lvl=info msg=“Initializing TracingService” logger=server
t=2019-01-23T15:54:02-0300 lvl=info msg=“Initializing Stream Manager”
t=2019-01-23T15:54:02-0300 lvl=info msg=“HTTP Server Listen” logger=http.server address=0.0.0.0:3000 protocol=http subUrl= socket=
t=2019-01-23T15:54:33-0300 lvl=info msg=“Request Completed” logger=context userId=0 orgId=0 uname= method=GET path=/ status=302 remote_addr=152.233.164.156 time_ms=1 size=29 referer=
t=2019-01-23T15:54:41-0300 lvl=info msg=“Request Completed” logger=context userId=0 orgId=0 uname= method=GET path=/ status=302 remote_addr=152.233.164.156 time_ms=0 size=29 referer=

P.S. I forgot to mention that I’m using InfluxDB

At this moment, I tried to use nginx e again it doesn’t work to a external network. The strange is that worked only to the local network as before.

I created a EC2 server on AWS.
I installed the Grafana application.

And when I tried to access the aplication from my house it worked!
But when I tried to access from my work it didn’t.

In other words …
When the server is in my work’s network every client stays stuck on the loading page.
When the server is out of my work, only clients from my work’s network stay stuck on the loading page.

Anyone know what it could be?

Hello Ricardocads,

Have you already fix this? The same thing I experienced with the lates version as of 2020.
I have deployed grafana locally in our home, and try to port forward 3000 on the internet, when I tried to access it outside (via internet), only the loading screen pop out.

Thank you.

Try using a different browser. I had the same issue using IE. I switched to Chrome, then the page loaded.

Just had the issue on Firefox. Fix was to clear the browser cache.