Issue with dashboards loading from a datasource : "Dashboard not found" error message

Hello,

We have developed a datasource and it includes demo dashboard. I have declared them into the plugin.json file and they appear in Grafana under the “Dashboards” tab when I create my datasource.

However, when I click on “Import”, I’m getting a “Dashboard not found” error message.

I’m using the latest Grafana on Windows and I traced disk access (with an external tool : Process Monitor) and the dashboadds files appear to be loaded by grafana server.

|13:18:03,4841370|grafana-server.exe|14564|CreateFile|E:\seb\grafana\data\plugins\infovista-vistamart-datasource\dashboards\datacenter_health.json|SUCCESS|Desired Access: Generic Read, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Disallow Exclusive, Attributes: R, ShareMode: Read, Write, AllocationSize: n/a, OpenResult: Opened|
|---|---|---|---|---|---|---|
|13:18:03,4843008|grafana-server.exe|14564|ReadFile|E:\seb\grafana\data\plugins\infovista-vistamart-datasource\dashboards\datacenter_health.json|SUCCESS|Offset: 0, Length: 512, Priority: Normal|
|13:18:03,4843639|grafana-server.exe|14564|ReadFile|E:\seb\grafana\data\plugins\infovista-vistamart-datasource\dashboards\datacenter_health.json|SUCCESS|Offset: 512, Length: 1 024|
|13:18:03,4844204|grafana-server.exe|14564|ReadFile|E:\seb\grafana\data\plugins\infovista-vistamart-datasource\dashboards\datacenter_health.json|SUCCESS|Offset: 1 536, Length: 2 048|
|13:18:03,4845535|grafana-server.exe|14564|ReadFile|E:\seb\grafana\data\plugins\infovista-vistamart-datasource\dashboards\datacenter_health.json|SUCCESS|Offset: 3 584, Length: 1 816|
|13:18:03,4848554|grafana-server.exe|14564|CloseFile|E:\seb\grafana\data\plugins\infovista-vistamart-datasource\dashboards\datacenter_health.json|SUCCESS||

Why am I getting this error ? Is there any debug flag to activate ?

FYI, the datasource is located on https://github.com/infovista/vistamart-datasource/releases/download/v2021.3.0/infovista-vistamart-datasource-2021.3.0.zip

Thanks in advance

Cc @marcusolsson

Seb

Issue found : id was not set to null.

Seb