Issue with Azure AD Auth with Grafana Running in Container

Has anyone tried setting up Azure AD authentication with grafana running in containers successfully? I am trying to set up grafana in Azure App service for linux which is basically docker container, image pulled from official grafana image.
While on a regular compute I am able to set up Azure AD auth easily I am not able to wrap my head on how to get it working Azure Web App service for Linux.
I have followed the documentation step by step however whenever I specify reply URL in root_url parameter I am not able to load grafana. I keep on getting following error:
If you’re seeing this Grafana has failed to load its application files

  1. This could be caused by your reverse proxy settings.
  2. If you host grafana under subpath make sure your grafana.ini root_path setting includes subpath
  3. If you have a local dev build make sure you build frontend using: npm run dev, npm run watch, or npm run build
  4. Sometimes restarting grafana-server can help

Obviously without root_url specified I get AADSTS50011 Error. I have tried specifying Server.Domain, Protocol, Port parameters but having similar issues. Grafana is official image from docker hub. I am accessing grafana as url e.g. url for Azure App Service which proxies/load balances requests to Grafana containers. (used the same with root_url with /login/generic_oauth, also tried specify domain,port etc).
Even tried my luck with https vs http as in Azure AD sign in error reply url
I am using MySQL as persistent store (I don’t think that matters here). Any insights into on what I am doing wrong will be appreciated.

Got it working, Nothing to do with Containers. I was Confusing root_url with reply_url. root_url doesn’t need to have /login/generic_oauth suffix as we have in reply_url. :blush: