Grafana under nginx - Azure AD OAUTH

  1. Running NGINX proxy to ~/grafana & ~/grafana/api/live on port 80 proxy to port 3000
    2.Running ubuntu docker with grafana with below

[server]
root_url = %(protocol)s://%(domain)s:%(http_port)s/grafana/
serve_from_sub_path = true
protocol = http
http_port = 3000

[auth.azuread]
name = Azure AD
enabled = true
allow_sign_up = true
client_id = CLIENTID
client_secret = SECRET
scopes = openid email profile
auth_url = Sign in to your account
token_url = login.microsoftonline.com/MYTENANTID/oauth2/v2.0/token
allowed_domains =
allowed_groups =

Azure App Registration reply url set to : localhost:8080/grafana/login/azuread

After Azure AD authentication the redirect url went to localhost:3000

Why is this behavior ? In such case whats the url to be given to reflect nginx:8080 ?