Influx/Grafana : Getting - InfluxDB Error: retention policy not found

i All,

I have recently installed clean builds of both Grafana and Influxdb. I am collecting data from around 20 sensors via mosquitto/node-red into a series of tables into an Influxdb - mydb.

This is a vanilla installation with no changes made from the default installation. The data is definitely arriving and being stored in the tables. I can pull it out via a simple command line query.

When I point Grafana (Again a vanilla build) at the DB, all queries result in the error message above

I have tried adding a non-default retention policy - this has not changed the situation

Constructive advice gratefully received.

1 Like

Ok - So its not just me - I was starting to wonder if I had missed something fundamental .

This is a re-installation of both Grafna and Influx in my case, my dashboard were previously working perfectly

I have run into a dead stop in the absence of any other guidance

I found problem with my instance. I had in dashboard variables this query:

SELECT _name AS “name” FROM udpmetrics.“default”._measuements WHERE host =~ /$hostname/

I changed “default” to “autogen” and it works now.