Influx comparison problem

I have influxdb and grafana on a Raspberry Pi and it has been working for some time and have 6 different temperature sensors on one graph working well. However, due to sensor power glitches I have a value of -3000 in one of them and +6000 in another.

Accordingly the graphs are flatlining as all the other inputs are between zero and 30c.

Sadly comparisons simply will not work. When I open the relevant panel I have SELECT field(value) WHERE and a + sign.

If I add any comparison like value < 100 or field(value) < 100 the line for that graph simply disappears…

Am I missing the point - seems a fairly straight forward comparison?

I understand there is no DELETE in influxDB unlike other databases so I don’t know how to delete bad figures.

What version of InfluxDB are you using? The documentation indicates that both DROP SERIES and DELETE are supported in version 1.2 - the latest version.

Iwas on 1.01 - I’m now on 1.2 - thank you for that - but not sure how to do delete… and I’ve tried again - in Grafana where you have the input field adding WHERE value < 100 - and the graph line still disappears. As I don’t know what I’m doing I also tried adding WHERE field(value) < 100 same result.

Any feedback really appreciated.

If you open the Google Chrome developer console do you see any errors? And can you check the response to see if you are getting anything back from InfluxDB (see below for instructions on how to do that).

How to troubleshoot metric queries.

Hi there

Failed to load resource: the server responded with a status of 400 (Bad Request)

So to be clear - this is what it says


SELECT “value” FROM “sidewall/fromesp/temperature” WHERE $timeFilter

This doesn’t.

SELECT “value” FROM “sidewall/fromesp/temperature” WHERE “value” < 100 AND $timeFilter


If you happen to know what is wrong with above - that would be great.

Also if you know how to achieve the same with all records on a given set - using DELETE…

From the Pi command line - “influx” or “influxDB” do nothing.